SaabCentral Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My apologies in advance- - this is like my fourth post ever.
I'm trying to figure out what is wrong with my 2003 9-5 Linear 2.3t, sedan, 5 speed, 193k miles. I have no one in the area who knows Saabs at all. It starts and runs fine, but when the turbo gauge gets above halfway the engine stutters and jerks and loses almost all power. The check engine light usually starts flashing, and usually the electronics act weird, like the stereo emits a snapping static crackle that is in synch with the check engine light. That all returns to normal if I turn it off and back on, until I accelerate hard again and it all happens again. The only code I get from a generic reader is P0441, which is the emissions purge valve, and I don't think that would produce these symptoms. I would be willing to start replacing parts if I had a clue what to try first: Crankcase sensor? Ignition coils? Vacuum hoses? Does anyone have any ideas? Any help would be immensely appreciated.
 

·
Registered
Joined
·
1,052 Posts
DIC (Direct Ignition Cassette) may be failing. It won't necessarily set a code. Replace it with a genuine Saab part with a SEM label. Latest part number is 55559955. Don't replace it with a less expensive aftermarket part.
 

·
Registered
Joined
·
842 Posts
I don’t imagine the P0441 has anything to do with the strange engine behaviour but when you get around to it - first advice is usually to ensure the gas cap is sealing properly. In my experience the next thing would be the purge valve, located behind/below the mass air flow sensor. The reed valve is susceptible to dirt jamming, and having ripped one apart I can’t see how to reassemble after you clean it. I believe the valve is generic but it’s heat sealed onto a 180 degree bent rigid pipe. I’d remove it and see whether 12 volts operates the valve. One for the pick ‘n’ pull, I’d suggest.

As regards the engine running, if it were mine I’d go with Steve’s advice. Even better - borrow a DIC to test, as it’s an expensive purchase only to find it’s not the culprit.
 

·
Registered
Joined
·
8,163 Posts
The static is odd. Is the current DIC properly secured with four scews? Are the various ground wires in good condition?

There are various things that could be going on, but from your description, I wonder if it's something electircal--a wire bending or being pulled when the engine is rocking over under torque.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #6
My apologies in advance- - this is like my fourth post ever.
I'm trying to figure out what is wrong with my 2003 9-5 Linear 2.3t, sedan, 5 speed, 193k miles. I have no one in the area who knows Saabs at all. It starts and runs fine, but when the turbo gauge gets above halfway the engine stutters and jerks and loses almost all power. The check engine light usually starts flashing, and usually the electronics act weird, like the stereo emits a snapping static crackle that is in synch with the check engine light. That all returns to normal if I turn it off and back on, until I accelerate hard again and it all happens again. The only code I get from a generic reader is P0441, which is the emissions purge valve, and I don't think that would produce these symptoms. I would be willing to start replacing parts if I had a clue what to try first: Crankcase sensor? Ignition coils? Vacuum hoses? Does anyone have any ideas? Any help would be immensely appreciated.
Update: I put in new spark plugs and a $89 new, no brand, ignition cassette from Amazon. The procedure was literally less than 15 minutes, and it runs WAY better. Oddly, it still hiccups at the rpm/boost peak under hard acceleration in first gear. Otherwise it runs like a normal car, finally. I don't expect to get much out of the cassette in the long run, but it was all I could afford right now. HUGE THANKS to you all who recommended the cassette- -I wouldn't have tried it without your advice, and I would still be miserable. Many, many thanks!
 
1 - 6 of 6 Posts
Top