SaabCentral Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I just bought a 92 900 conv with a whopping 345K Miles, yes you saw it correctly, anyway its an automatic trans and it only engages in reverse gear after it warms up for about 10 or so miles. To attempt to correct this, I first had the transmission fluid chaged with 3 quarts of type F and one container of Lucas transmission. Still the same results, so I asked my old saab mechanic and he suggested to do two things, first remove the pan and unbolt the mesh trans filter and clean with carb cleaner until the liquid becomes clear and then replace with fresh fuild. Also he said to adjust the transmission bands and if these two things don't work he says that the problem is internal. I understand the only tool needed to adjust the bands is the 1/4 inch spacer tool that can be improvised with something else. Also I should say that it doesn't want to shift in the final forward gear until warm as well. The only other problem with the car is that the linkage is off , the car goes forward only in number 2 while cold and only goes in reverse when hot in neutral position. I would greatly appreciate any input as I love the car and don't want to be deterred by the mileage, and want to make every attempt possible to prolong the trans problem even if its only a temporary fix until it ultimately goes out.:(:nono;:D
 

·
Registered
Joined
·
219 Posts
Start with the mesh filter, I cleaned off the filter on a RangeRover classic that banged into gear on the autobox but after a filter clean and trans fluid change was smooth as silk, My dad also did the same on his Grand Cherokee and again a massive improvement on the autobox:p
 
1 - 2 of 2 Posts
Top