SaabCentral Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
Hi all....

I just replaced the antenna mast on my 2000 9-3 HB- as the cable had broken. Everything went smoothly. I purchached a replacement mast from thesaabsite.com, and I went with AFT instead of OEM. I took out the broken piece... and...after making sure the motor was in the down position...I disconnected everything...put the new mast into the existing sheath....and carefully pushed the new cable into the mechanism. The new mast goes up and down smoothly...but I hear a loud click from the mechanism about 1 second after it goes all the way up, and again, after it goes all the way down...as if it's not adjusted correctly. I thought these things self-adjusted? Is this because AFT cable is shorter than the OEM version, or did I do something wrong? Thanks again! Really appreciate your thoughts.

Tom
 

·
Registered
Joined
·
12,353 Posts
I just changed my antenna yesterday. I bought the non-OEM antenna from eEuroparts for $8.33,

The lowest section of my antenna had a slight kink in it and wouldn't fully retract. I took the antenna housing apart, removed the antenna and toothed-cable. The only problem that I had was that I couldn't turn the radio off and run back to feed the new cable into the housing quick enough. Finally, I used an 8' 1x2 through the hatch to turn the radio off while I was ready to feed the toothed-cable into the unit. It worked great and in less than a minute the new antenna was in.

I did notice that I get one click when the antenna is either extended or retracted. But, it still works and that's all I care about... Ron
 
1 - 4 of 4 Posts
Top