SaabCentral Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
124 Posts
Discussion Starter · #1 ·
I am getting a constant rear light failure message. I pulled all the bulbs, lightly sanded the contacts on the bulb and then applied dielectric grease.

All the contacts look good.

So, what light bubls are checked? All of them?
I am going to try replacing some bulbs but dont want to spend mone I dont need too.

Do I need ot get them from the dealer?
 

·
Registered
Joined
·
1,464 Posts
All of them are replaceable with standard auto parts store bulbs. Did you check that they all illuminate, including the brake lights?
 

·
Registered
Joined
·
898 Posts
Make sure both filaments in the taillights are working. Both the "headlights on" brightness and the actual braking lighting. Either one will trigger the message. SID does not check for the third brake light either so its one of those two. Might as well replace them both, they are cheap and you will have a spare
 

·
Registered
Joined
·
124 Posts
Discussion Starter · #4 ·
I think I figured it out. There is one bulb that does the brake an "head lights on" Well the same filament in both bulbs was burnt out.

I haven't figured out what I was missing because the tail lights worked and the brake lights worked.

Looking at the bulb you could't see the break. I had gone back to check each one and when I did I pulled them out on a white paper towel. I could see the glass was a little black on one side. When I shook the bulb I could see the break. I will replace both this morning and see what happens.
 
1 - 5 of 5 Posts
Top