SaabCentral Forums banner

41 - 52 of 52 Posts

·
Registered
Joined
·
173 Posts
Discussion Starter · #41 ·
Hmmm... when I look at the EPC for the 9-3, it doesn't have anything listed but the b205 & 235. There's nothing for the B204 that you have. When I look at the 900 for the B204, it has the other one with the small rectangle.

Maybe one of the T5 '99 guys here knows...
Here's to hoping. I'm really at a loss.

Hmm,

That is the base gasket/oring?. Check out rockauto as they have a few pics...

Fuel/air..throttle body...gaskets...etc..

I saw nothing on Eeuro...I guess we are getting antiquated..)
I've looked literally everywhere I can think of. Rockauto, eeuro, saabpartsusa, saabparts, jimellissaab, ebay, amazon.

I'm thinking I'll just go grab some gasket material to trace and cut from.
 

·
Registered
Joined
·
173 Posts
Discussion Starter · #42 ·
In other news:

I cleaned the ever-loving sh*t out of the TB. The throttle response is slightly better and the accelerator pedal movement is a bit smoother, HOWEVER the random stalling issue remains.

Frustrated. It's really obnoxious having to feather the gas all the time when idling. Especially on an incline :roll:
 

·
Registered
Joined
·
173 Posts
Discussion Starter · #43 ·
Got a new (aftermarket) DIC yesterday, plopped it in. It seems to run a *little* smoother, and for most of the day wasn't stalling at idle. Thought the problem was solved.

Unfortunately, this was not the problem. It finally did it after some extended driving and then sitting in front of my house to give it an honest test. Sat for about two minutes then it finally sputtered out. Did the same a few hours later.

I hear hitting things with hammers sometimes works.......
 

·
Registered
Joined
·
173 Posts
Discussion Starter · #45 ·
Also, maybe this is somewhat related? I don't know....BUT

Whenever I get fairly low on fuel and fill it up to about 3/4 tank, usually the first time I fire it up after filling it'll be stumbling all over itself at around 500 RPM, I have to cycle through some revs for about a minute before it stops dropping down so low and idles "normally".

Maybe something with the fuel system is going haywire? Would this possibly be what's causing my stalling at idle as well? Just not quite getting enough fuel sometimes?
 

·
Registered
Joined
·
12,793 Posts
In theory you should get a CEL for a bad one, but maybe not always the case. Normally a bad one will act like a vacuum leak (rough idling, possibly stalling) the other key is that it can be worse on a full tank of gas. You could swap in a known working one or just install a new one, might not fix the issue, but it's not an expensive part and quick and easy to change.
 

·
Registered
Joined
·
173 Posts
Discussion Starter · #50 ·
To anyone that has been following and providing input on this thread, thank you all so much.

I am happy to report that my stalling problem seems to have been cured. It's been about 24 hours without a single stall, all without feathering the gas. Doesn't seem like such a long time, but when it would stall at nearly every stop light, it feels like a huge accomplishment.

If the problem truly is fixed, it was the evap purge valve causing the issue. I popped it out early yesterday and cleaned the ever loving sh*t out of it with TB cleaner. Threw it back in, laced the battery back up, and it's been doing well ever since. :cheesy:

Now to track down where my coolant is disappearing to..........
 
41 - 52 of 52 Posts
Top