SaabCentral Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I recently bought myself a '03 93ss ...
and upon purchase i checked everything exept.... the radio...

cd player/changer , satnav (altough not always traffic info....) work fine and my turn signals make sound
but i only get static from my radio,i went trough all the stations (which off course he doesnt find) am/fm1/fm2 ,... and i get nothing... :(

so after searching and reading about the radio (and his problems)i removed my c-pillar ...

could you please help my out and take a look at if there is anything wrong?



i checked for loose connections... NONE :cry:
any tips/feedback would be greatly appreciated
 

·
Super Moderator
Joined
·
8,928 Posts
is the static with the demister on/off or both..check there is power going to the amp..everthing looks ok from the pic..
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
Demister on/off doesnt make a difference...

*check amp for power* the amp under the drivers seat (amp1)?
I can see a red light and my turn signals make sound... i'll double check as soon as i can , im @work atm.

Are there any other obvious point that i can check for faults?
I really really dont want to take my whole car appart so i can listen to some radio :cheesy:

Thnx for the quick reply! Appreciate it!
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
Silly me :cheesy:

Didnt had a voltmeter to test it :confused:,
I'll check that first then , 2bad i already put the trim back:roll:

I guess i should check for power at the "9v. Like" connector then?
 

·
Super Moderator
Joined
·
8,928 Posts
there could also be a problem with the filter on the earth side of the rear screen,behind the other c pillar..

might be worth pulling the fuse aswell,don't know which one,don't have my manual to hand..
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
I think that would be fuse nº14 (fascia)
Thought this would be a easy fix.... :nono;

Ill have another look tomorrow , thx for all the advice Aerojon!
I did took some pictures of the removal of the parcel shelve/c pillar , its actually a straight forward job... but if it could be a help to anyone?
 
1 - 7 of 7 Posts
Top