SaabCentral Forums banner
1 - 3 of 3 Posts

·
Registered
2010 saab 95 / 2017 volvo v60
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello, New to forums in general and this is my first post. I have a 2010 95 aero with the harmon kardon sound system. After I finished Work on the valve body in the transmission, and went through the rear diff, an issue with the radio appeared. Sometimes when you get in the car to drive there will be no radio, no blinker sound, no chimes... but if you stop at a store or something and come back, it will work when you start it back up. battery seems good and I did try charging it. No moisture in the car I could find, and the head unit seems to work but without sound. Really scratching my head on this one. I hear the main amp is in the passenger footwell behind the carpet? Help Is hugely appreciated.
-Ryan
ps if anyone needs help with trans shifting issues I may be able to help :)
 

·
Registered
Joined
·
33 Posts
I had fits with my UYS (RPO 515-170, non-HK, but with Nav). I tried mailing it to a competitor (~$100 with insurance) who mailed it back and said he couldn't fix it. I finally sent the head unit to United Radio. They successfully fixed it, but it was something like $650. Mine was only around a year old and would work sometimes and not work other times. I do not recall a correlation with no turn signal sound.
Mine is 2011 9-5 2.0T m/t.
Bought the car untitled in April 2012 and the problem began sometime before May 2013. Radio would play, then not play, then work again, etc. Frustrating as hell.

To conclude, it you finally decide it is the head unit, then I recommend United Radio. The competition could not fix it.
 
1 - 3 of 3 Posts
Top