SaabCentral Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi!

I just bough my first Saab. Its a 9-3 2007 2.0T. I really enjoy it but I have a problem with my radio. When the car is on, it is making a constant little annoying buzzing sound. I opened this up and found out that the sound stops when I unplug these wires (see photo).

What can I do? Do I need to change my radio, or if its only the wires, what can I do?

Thanks
273133
 

·
Registered
Joined
·
7,446 Posts
Hi and welcome to SC.
You have 1 or more wires which have cracked insulation.
There is TSB (367-2684) of this issue. TSB says that you need to replace 9 wires from HU to H 33-4 connector. H33-4 is at bottom of right A-pillar.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thank you for your answer.

Sorry if I didn't describe it well.
I looked at TSB 367 2684 and it says: Crackling Noise From Speakers.
But in my case, I think the noise really comes from the radio and Its not a crackling sound but its more of an high pitch whine.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Ok, well I don't really know how to do this and it doesn't seem like there is some simple guides about this stuff. I might just ask a specialist to check it. Thank you.
 

·
Registered
Joined
·
62 Posts
does anyone have this actual TSB to see.

I am working on friends saab Combi and we just unpacked the radio previous owner had in.

Also if anyone has a pinout or color guide for the factory side of the harness.

as unsure of 2-3 wires but cannot find the color codes.

for the 2007 Sport Combi.
 

·
Registered
Joined
·
62 Posts
does anyone have this actual TSB to see.

I am working on friends saab Combi and we just unpacked the radio previous owner had in.

Also if anyone has a pinout or color guide for the factory side of the harness.

as unsure of 2-3 wires but cannot find the color codes.

for the 2007 Sport Combi.
UN HACKED I MEANT
 
1 - 7 of 7 Posts
Top