SaabCentral Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
622 Posts
Discussion Starter · #1 ·
Alright so I got my 9-3 the other day and to be honest I'm good working on mechanical things but once we get inside the car I hate it. I'm having a few issues. One would be my pops was driving the car from s.c to p.a and said that he tried to put a cd in and it just got stuck and then the radio wouldn't work. Then today I tried to put the window down on the passenger front door and it doesn't do a thing. No sound or anything like when a regulator is usually bad. I was trying to mess with fuses tonight and the few I found for the radio seemed to be ok and I couldn't get the thirty amp door amp out b'c I couldn't find my neednose pliers and it was dark and hotter than hell so I gave up. Any thoughts. Also sometimes when idling it makes a clicking sound that seems to go away when I depress the clutch. LOL I'm already thinking what did I get myself into. I love the car so far. The inside quality sucks compared to toyota or honda but performance and outside looks wise it's great, just having these electrical problems that aren't my strong suit at all.;oops:
 

·
Registered
Joined
·
622 Posts
Discussion Starter · #2 ·
No body has any tips? I tried looping amp 1 and I think it was already. I actually think it's a combination of my cd player and amp? Also did they make an indash cd changer with the 13 speaker system because the thing is a monster when I removed it.. Anyway all my fuses look fine..
I haven't had a chance to pull the door yet but doe's anyone have any insights on this. I've been reading and searching and all I can find are mile long threads with nothing actually being said.
 

·
Registered
Joined
·
4,300 Posts
No body has any tips? I tried looping amp 1 and I think it was already. I actually think it's a combination of my cd player and amp? Also did they make an indash cd changer with the 13 speaker system because the thing is a monster when I removed it.. Anyway all my fuses look fine..
I haven't had a chance to pull the door yet but doe's anyone have any insights on this. I've been reading and searching and all I can find are mile long threads with nothing actually being said.
Pull the negative battery terminal off the battery for 10-15 minutes to try a reset of most/all electronic modules. This fixed mine. Good luck.
 

·
Registered
Joined
·
58 Posts
That's true, but seems like multiple problems going on there. Maybe even a week battery getting ready to go, we all know what that does to our electronics.
Agreed! ;ol; it's worth trying the free "fix its" first. I honestly have no clue about the cd changer, but I had the same issues with my driver side window/mirror. I cleaned and reset the connection in the door. Works just fine now.

Keep us posted on the issues. There are tons of people willing to help on this forum. :p
 

·
Registered
Joined
·
4,300 Posts
Agreed! ;ol; it's worth trying the free "fix its" first. I honestly have no clue about the cd changer, but I had the same issues with my driver side window/mirror. I cleaned and reset the connection in the door. Works just fine now.

Keep us posted on the issues. There are tons of people willing to help on this forum. :p
Are u talking about the plug that connects to the door fron the car body at the hinge opening side? Cuz that did fix my passenger side mirror not folding in when I locked my car.
 

·
Registered
Joined
·
622 Posts
Discussion Starter · #8 ·
I'll try unplugging and replugging the door tonight. I'm assuming it's a simple connector. I can't tell if my radio is broken because of amp 1 or if it's the cd player as well. I tried using my army account to access chiltons and other manuals for this car but they conveniently leave the infotainment system out.
 

·
Registered
Joined
·
4,300 Posts
I'll try unplugging and replugging the door tonight. I'm assuming it's a simple connector. I can't tell if my radio is broken because of amp 1 or if it's the cd player as well. I tried using my army account to access chiltons and other manuals for this car but they conveniently leave the infotainment system out.
Easier to try simple first by unplugging the negative terminal from the battery. This will also reset the engine computer making the car feel really fast and peppy for like a hundred miles or so until it locks in the new settings. Like a cheap tune. Lol. Does the same as pulling the door conection, except it might be better not to loosen the seal on the door connector to keep moisture out if it's never been unplugged it's still factory sealed. And the door connector won't reset the infotainment system.
 

·
Registered
Joined
·
58 Posts
I'll try unplugging and replugging the door tonight. I'm assuming it's a simple connector. I can't tell if my radio is broken because of amp 1 or if it's the cd player as well. I tried using my army account to access chiltons and other manuals for this car but they conveniently leave the infotainment system out.
I had a blown amp1 within two months of buying my car. If you hear a "click click" when you use your turn signal, it's still working. ;ol; when mine blew, the cd changer still worked, but the radio, display and audio (Sid and radio) didn't work. Neither did the turn signal sounds.
 

·
Registered
Joined
·
622 Posts
Discussion Starter · #11 ·
I already tried pulling the negative terminal. What is confusing me is that the window doesn't make a sound like if it was a bad regulator. Just doesn't do a thing. It's been pretty peppy since I got it.. the car runs great and having 6 speeds is def an upgrade over any 5 speed i've ever driven but not having a radio and window will just drive me ****ing nuts, haha. Mechanically the car is strong I find myself doing 95 100mph without noticing it going down the highway.. need to get that speed warning working.
 

·
Registered
Joined
·
622 Posts
Discussion Starter · #12 ·
Im leaning towards amp 1 as well but b oth goldwing saab and saabradio want 350+ for it.. its not even a good amp lol I'm very tempted to rewire all the speakers and add in a new head unit and amps with fabbing a holder for the head unit and just leaving the cd player in the car to fill the space.. But if I did this I would have to loop the entire network right? Idk this pisses me off trully.
 

·
Registered
Joined
·
622 Posts
Discussion Starter · #13 ·
I had a blown amp1 within two months of buying my car. If you hear a "click click" when you use your turn signal, it's still working. ;ol; when mine blew, the cd changer still worked, but the radio, display and audio (Sid and radio) didn't work. Neither did the turn signal sounds.
How do you know if the cd player works if the radio doesn't work. Also I'm thinking that I have the single cd but the thing is huge when I pull my dual climate control the cd player takes up almost the whole space behind it.. seems a little ridiculous for a single. I know I have the 13 speaker system... I just tried to bypass amp 1 to no avail(to be honest I used some ****ty tubing and ruined a perfect optical cable to do it..

On the other hand does anyone have any good tips for pulling the handle cover without breaking it I felt like while prying I was very close to snapping it so I figured I'd save it for later and ask someone who has experience doing it.
 
1 - 13 of 13 Posts
Top