SaabCentral Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
Hi
Driver fan kicks in when hot and also when ac is on, seems low speed when ac is on and high speed when hot engine - seems normal to me.

Passenger fan not kicking on at all . Maxifuses 35 and 36 are good. How can I test the fan and it’s relay? I have to remove the whole bracket to remove the fans... is there some extension to plug into the fan directly ? Any other way to test fan and how can I test relay which has 2 leads for each fan. Do I use a multimeter? But the car needs to be on and hot to do that?

?
9-3
2003
Arc
 

·
Registered
Joined
·
55 Posts
Discussion Starter #2
Also
Hi
Driver fan kicks in when hot and also when ac is on, seems low speed when ac is on and high speed when hot engine - seems normal to me.

Passenger fan not kicking on at all . Maxifuses 35 and 36 are good. How can I test the fan and it’s relay? I have to remove the whole bracket to remove the fans... is there some extension to plug into the fan directly ? Any other way to test fan and how can I test relay which has 2 leads for each fan. Do I use a multimeter? But the car needs to be on and hot to do that?

?
9-3
2003
Arc
When car is off temperature gauge is all the way down. When i put key in on position gauge is already at 9pm?
 

·
Super Moderator
Joined
·
20,194 Posts
9 oclock on cold motor? Sounds like coolant temp sensor is bad.
 

·
Registered
Joined
·
55 Posts
Discussion Starter #4
Sounds about right but this doesn’t ?


About Engine Coolant Temperature Sensors

The engine coolant temperature sensor is used to measure the temperature of the engine coolant of the vehicle. The readings from this sensor are then fed back to the engine control unit (ECU), which uses this data to adjust the fuel injection and ignition timing.

I don’t think it’s going to adjust fuel injection? Or maybe that’s why right now it’s a rocket? I’ll save the old one just in case ?
 

·
Registered
Joined
·
1,348 Posts
The ECM will trim the injection and ignition values as the engine warms up.
 

·
Registered
Joined
·
55 Posts
Discussion Starter #6
Would coolant temp sensor possibly be cause of not enough injection at start up? Sometimes it starts up at 400 rpm
 

·
Registered
Joined
·
55 Posts
Discussion Starter #8
Yes it was sometimes . Today I changed coolant temp sensor and hasn’t done it yet though the gauge is pretty fast to go Down from temp being over 9pm when I turn car off but takes a while maybe 1 hr? To go to cold? Is that normal?
 

·
Registered
Joined
·
55 Posts
Discussion Starter #9
Yes it was sometimes . Today I changed coolant temp sensor and hasn’t done it yet though the gauge is pretty fast to go Down from temp being over 9pm when I turn car off but takes a while maybe 1 hr? To go to cold? Is that normal? (I was low on coooant when this happened but I think it happens all the time
 
1 - 9 of 9 Posts
Top