SaabCentral Forums banner
1 - 16 of 16 Posts

·
Registered
Joined
·
1,567 Posts
Discussion Starter · #1 ·
i had to drive on reserve for about 5 miles tonight, my sid told me i had 33 miles left till empty.. got to the station fine, filled her up with 40 bucks

start the car, needle goes to full.. 3 sec later, back to empty

tried it again, same thing..

i'm assuming i broke something.. i just hope it's an easy fix (trip to dealer, i'm covered.. just have to pay the 100$ fee) right?
 

·
Registered
Joined
·
2,045 Posts
it may be possible that your fuel sender is going. Its happening on my car. Basically i fill up the car and intermittenly my guage will read "empty" then pop back up and read fine. From the research i have done, there is no easy fix. You need to replace the fuel pump ($1000) :roll:
 

·
Registered
Joined
·
12,509 Posts
Very Right about being under warranty, this is a known issue with 03's many of us have had it done under warranty. Although from a recent thread it appears that just the Sender, not the whole fuel pump assembly is being replaced. Earlier on they replaced the whole unit.
 

·
Registered
Joined
·
1,567 Posts
Discussion Starter · #5 ·
good news, because i made an appointment to go in at 7am on friday.. but i have to wait with the car as i have no ride home (dealer is 11 miles away!).

do you know how long this generally takes once they have your car up on the lift?
 

·
Registered
Joined
·
12,509 Posts
It's acouple of hours for the job. They have to drain and drop the tank so try and get there with a little gas as possible in the tank, they'll appreciate it and it saves time.
 

·
Registered
Joined
·
2,045 Posts
JonV said:
Very Right about being under warranty, this is a known issue with 03's many of us have had it done under warranty. Although from a recent thread it appears that just the Sender, not the whole fuel pump assembly is being replaced. Earlier on they replaced the whole unit.
where is this thread you speak of?

And yes, good thing you have warranty!
 

·
Registered
Joined
·
2,045 Posts
yeah, i actually replied in that post. doesn't tell me anything. All the dealerships i have talked to said they replace the pump, and there is no part for the sender
 

·
Registered
Joined
·
12,509 Posts
Well that poster works for Saab, maybe they found its less expensive to repair than to replace? I just went by what he stated, that they just replace the sender in his shop.
 

·
Registered
Joined
·
1,567 Posts
Discussion Starter · #12 ·
strange.. after two days of this problem it went away.

is it possible that i OVERFILLED the tank? i've never put 40 bucks in the car before, and it seems after driving for a few miles (after driving a combined like 3 miles the previous two days) it is functioning fine..

is it on it's way out? i have an appointment for tomorrow morning, but the weather is awful..
 

·
Registered
Joined
·
1,567 Posts
Discussion Starter · #14 ·
yeah i don't think it's best to leave this alone. just figured i would check, as i know on some other cars when the tank is TOO full the reader messes up.

i'll set up an appointment next week when the roads aren't covered in ice and snow.
 
1 - 16 of 16 Posts
Top