SaabCentral Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
954 Posts
Discussion Starter · #1 ·
I just put the dash back on and the lower knee panel and then I go to lock the car up after I hooked the central locking relay up, it worked a half time meaning I locked the doors and it locked them then went to unlock them and now nothing. What could possibly be the problem. I have never had locking issues. could putting the panel on have knocked something off? Also putting that lower panel back on was a huge pain took forever with a friend helping guide.
 

·
Registered
Joined
·
5,464 Posts
Are you sure you didn't just jostle the relay when you installed the dash board?
 

·
Registered
Joined
·
954 Posts
Discussion Starter · #3 ·
That relay plugs in super hard there is no way it came off. And it worked for one key turn. I dont know how the central locking works. are there some hoses by the firewall that I might have knocked off or something.
 

·
Registered
Joined
·
10,081 Posts
davidlytle said:
That relay plugs in super hard there is no way it came off. And it worked for one key turn.
Sounds to me like something internal to the box didn't like being moved and is sulking.

I spent quite a while troubleshooting mine, determined everything to the box is fine, resoldered all the internal joints in the box - and it still doesn't work, unless the relays are prodded manually.

Then the car was hit while parked, and it worked a couple of times as it should, then didn't but unlocked everything later whilst I was driving along - then it went back to sulking totally.

I dont know how the central locking works. are there some hoses by the firewall that I might have knocked off or something.
No hoses. Not even Saab are perverse enough to do vac locking...

Pins 1 and 2 in the control box are alternately grounded by the driver's door lock - one pin for "lock", the other for "unlock". The box sees the change, and fires a voltage briefly down another couple of pins (7 & 8) which goes to the other door locks to lock/unlock them.

If you've got a multimeter, check you've got live to pin 4, earth on pin 3, and that 1/2 get earthed by the driver's door. If they're all fine, and nothing fires, the box is dead. If some fire, there's wiring issues from the box to the non-firing locks. If pins 1/2 aren't switched, the problem's probably on the door lock.
 

·
Registered
Joined
·
954 Posts
Discussion Starter · #5 ·
where is this box you speak of? also when I had to bolt the the knee bulster to the bulkhead, through the fender I might have messed up some wires. What wires are in the driverside well near the bulkhead where you screw the nut on to hold the knee bulster? there are a few plugs there.
 

·
Registered
Joined
·
18,382 Posts
TooMany2cvs said:
No hoses. Not even Saab are perverse enough to do vac locking...
Mercedes :lol:

I can't believe these nutter engineers, they put a vacuum system for everything. Central locking, HVAC flaps, engine fuel cutoff, etc etc. And then they put the same one on a car that doesn't actually have any vacuum (eg diesel) so they put a vacuum pump. Invariably the vac pimp wears out and also all the lines leak so once it is 10 years old, nothing works. Crazy Germans :lol:
 

·
Registered
Joined
·
10,081 Posts
davidlytle said:
where is this box you speak of?
On a RHD car, get in the passenger footwell, undo the torx screw in the air vent under the knee trim, and pull that down slightly. There's a box on a metal bracket clipped to the vent. That's the locking control box.
 

·
Moderator
Joined
·
4,637 Posts
davidlytle said:
where is this box you speak of? also when I had to bolt the the knee bulster to the bulkhead, through the fender I might have messed up some wires. What wires are in the driverside well near the bulkhead where you screw the nut on to hold the knee bulster? there are a few plugs there.
Those are electrical connections to the door. Windows, central locking and mirror adjusters. It would be worth your while disconnecting and reconnecting these connectors.
 

·
Registered
Joined
·
954 Posts
Discussion Starter · #9 ·
That box on the foot heater thing is the relay right? So that might be bad? I had it disconnected for about 2 weeks then reconnected. I will check the fenders to see if I broke any wires. So are saabs vaccum regulated?
 

·
Registered
Joined
·
954 Posts
Discussion Starter · #10 ·
Well I think I figured out what is wrong now what??? I touched a wire when the door was open on the driver side then the locks would open. when I would wiggle the wire on off on off and so on. How am I supposed to get in there to fix the wires?
 

·
Registered
Joined
·
10,081 Posts
davidlytle said:
Well I think I figured out what is wrong now what??? I touched a wire when the door was open on the driver side then the locks would open. when I would wiggle the wire on off on off and so on. How am I supposed to get in there to fix the wires?
Which wire where?
 
1 - 12 of 12 Posts
Top