SaabCentral Forums banner

1 - 20 of 43 Posts

·
Registered
Joined
·
139 Posts
Discussion Starter · #1 ·
I took the dash apart (wasn't as hard/complicated as I'd read) and checked all the bulbs to see why they didn't seem to be working.

The previous owner "fixed" problems (or had them "fixed" by a mechanic) by removing indicatior lights. 2 bulbs were removed from the gauges. The "coolant warning" and shift up. I understand the shift light...but the "coolant warning" light!?! If the lights on then fix the [email protected]% $#mn! problem, don't remove the bulb!! Makes me worried about the quality of care it received....

The left side dimmer should work now, zip-tied in place, and the tach works perfect...don't have to wack it to get it to do something.

The far left light (check engine soon) is on now, and it was idling horriably...till the light came on. I assume '89 900's aren't OBD1 compatiable (stick a paper clip in...count flashes...thats the code)...how do I check the "codes"?
 

·
Registered
Joined
·
948 Posts
Check your Bentley manual.
On my vert there is a socket I can plug "paperclips" into for the engine light to display the fault codes. I think some models had them in different locations.
 

·
Registered
Joined
·
139 Posts
Discussion Starter · #3 ·
Haven't had the "extra" ~$80usd for a Bently yet. Only unconnected thing I've found is under the rear seat and it doesn't appear to have anything to connect to.

Now that it's dark out I went and checked to see which lights acutally work and which don't. Ovbiously all the waring lights worked fine (nice & bright, even for daytime). Only 2 out that I can tell and I wish I had changed one of 'em while I had the dash apart. The other one is the back light(s) the stereo uses (the EQ is fine...kinda odd). The dash one is the one that shines on the right side of the gauges, one of the big 'uns.
Oh...all the outside lights work fine too though I kinda wish the front reverse lights didn't (they're rather creepy if you ask me).

Sylvania (input Saab, '89, 900, if needed) implies that all the gauge/instrument cluster bulbs are the same but the one thats blown is one in the pair that is easially 2x the size of the rest...any ideas?
 

·
Registered
Joined
·
5,464 Posts
What coolent warning light?
 

·
Registered
Joined
·
5,464 Posts

·
Registered
Joined
·
962 Posts
fetchitfido said:
Sylvania (input Saab, '89, 900, if needed) implies that all the gauge/instrument cluster bulbs are the same but the one thats blown is one in the pair that is easially 2x the size of the rest...any ideas?
The warning lights use a 1.2W "grain of wheat" bulb. The 2 which are larger are 5W ones which are used for general illumination of the instrument panel.
 

·
Registered
Joined
·
139 Posts
Discussion Starter · #8 ·
It's in the same area as the low fuel light, but thats not it. I have a triangular set of bulbs, all appear to be blocked off from each other (EXH, low fuel, and coolant). I think that that hole in the "power paper" in yours is the same thing, but yours doesn't appear to have a hole in the plastic too like mine does.
I'll try to get a pic later today or tomorrow, sounds like it's an odd setup. Gotta take it apart again for that 5w bulb anyway...maybe I'll get a brighter one.
 

·
Registered
Joined
·
10,081 Posts
fetchitfido said:
It's in the same area as the low fuel light, but thats not it. I have a triangular set of bulbs, all appear to be blocked off from each other (EXH, low fuel, and coolant).
Yep, I've got three bulb holes in the dash, too - and in the "speedo donor dash" I killed.

Both were the same.
The fuel warning has a bulb in - which works. Frequently.
EXH has a bulb in, despite not being used this side of the pond.
The temp warning has a plastic blanking plate in. On both dashes.

They're the only bulbs which can't easily be changed from the speaker hole.
 

·
Registered
Joined
·
962 Posts
fetchitfido said:
Gotta take it apart again for that 5w bulb anyway...maybe I'll get a brighter one.
Don't. The heat'll damage the plastic surround & the fragile tracks. Stay with the 5W. But getting new ones do help as they blacken with age.
 

·
Registered
Joined
·
139 Posts
Discussion Starter · #13 ·
So it wasn't thier stupidity to have a "dummy" light in the temp spot? Thats stupid...why bother making it an option to have a light there?

Can't go higher then 5w? Thats annoying...might be brighter as it is if the plastic trackes were clear instead of green.
 

·
Registered
Joined
·
10,081 Posts
fetchitfido said:
So it wasn't thier stupidity to have a "dummy" light in the temp spot? Thats stupid...why bother making it an option to have a light there?
<shrug> One dash fits all versions. Some of which - some markets, some specs - may have a temp light, others not.

Mine's got bulbs in the EXH light (never used in the UK or anywhere as late as '90), Shift Up light (never used in the UK), ABS light (not fitted to mine), and a couple of others. You want daft? That seems to be it, rather than a blanking plug in a bulbhole that isn't used.

B'sides, why do you need a light if you've got a gauge?
 

·
Registered
Joined
·
139 Posts
Discussion Starter · #15 ·
The light could be to warn me about a low coolant level situation, whcih amy not be the 1st thing someone thinks of when the car overheats. It just really bothered me to see a couple lights looking like they were removed, and a legit safty light (as opposed to a not legit light like the fasten seat belts) looked to have been replaced with a blank.

Gotta figure out what I did with the manual...but it didn't notify me that 5th gear was in the most f-d up place so it probably won't mention this either.

Got 2 bulbs for $1.02 so now I get to wait till tonight to see if it helps any.
 

·
Registered
Joined
·
10,081 Posts
fetchitfido said:
The light could be to warn me about a low coolant level situation
It could...

...if there was a coolant level sensor in the header tank. Which there isn't.

whcih amy not be the 1st thing someone thinks of when the car overheats
...whether or not there's a light on...

Anyway, let's be honest. The first thing probably the majority of drivers will think is "Oooh, wonder what that light means. I'll ring the garage tomorrow. If I remember"

If they're actually going to stop and try and do something sensible about finding the problem, they'll find the low level quick enough.

Gotta figure out what I did with the manual...but it didn't notify me that 5th gear was in the most f-d up place so it probably won't mention this either.
<baffled> Where did you expect it to be?
 

·
Registered
Joined
·
962 Posts
TooMany2cvs said:
Anybody tried any of the LED replacements?
I've often been tempted to when I see them at shops. But the dimmer/rheostat will definitely not work with LEDs....
 

·
Registered
Joined
·
230 Posts
that cooling system / temperature light

I think was only used in Japanese markets, I remember looking this up on the saab EPC (electronic parts catalogue) once... and i was looking up something else, and I'd wondered why this wasn't enabled on my SPG, and that's why -- only Japanese market cars.
 

·
Registered
Joined
·
139 Posts
Discussion Starter · #19 ·
TooMany2cvs said:
<baffled> Where did you expect it to be?
Above Reverse, like every other 5spd I've driven. This one has 5th above the space between 4th and R, not directly above R. I've gotten used to it now so it's not a problem finding it but it was extremly annoying at first, and something that *should* have been mentioned in the manual...unless I need to take it apart to re-align it :roll:

Kinda sad that 2 brand new 5w bulbs are out shined by 11 year old bulbs in my other car. I can clearly see that the gauges are lit in my other car on the lowest setting, but have to hold my arms 'round the dash in the 900 on the brightest setting. I think its the plastic stuff thats impeding it...can they be removed and cleaned?

So now I feel stupid...it was a Japan only thing that I was getting worried about with the coolant light? lol

In my defense...my last/only experience with an "import" was a '94 Hynudai Elantra. Burned a valve or some such attepting to get it above 90mph (top speed was claimed to be 113mph and ... I was 18 at the time)....stupid Hyundai.
 

·
Registered
Joined
·
18,382 Posts
I don't understand, there is no coolant lamp!
 
1 - 20 of 43 Posts
Top