SaabCentral Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter · #1 ·
well i put my td04 on with a brand new viggen ic and new hoses and now around 4500rpm i go from 15psi to about 10 psi it is killing me i never had this problem with my t25 can anyone help!!!!!
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #3 ·
when in 3rd gear it will pull great then it will loss boost slowly down to 10 psi blow off valve is good all clamps are tight just losses boost
 

·
Registered
Joined
·
1,816 Posts
Do you have the stock BPV? If so they can only withstand 15psi maybe once :roll:.
 

·
Registered
Joined
·
642 Posts
yea if you need to upgrade the BPV go with the Forge or Statmosphere Hyperboost
 

·
Registered
Joined
·
3,009 Posts
Yes, that's the turboxs type rfl is the one with the big horn. Mine hold 15 psi just fine, so its not that. What do you have for a boost controller? Some get dirty and will surge for a bit, then boost will settle. Mine did this, but after I cleaned it, boost was much more consistent.
 

·
Registered
Joined
·
642 Posts
how'd you go about cleaning it? just curious for future maintence. Compressed air?
 

·
Registered
Joined
·
3,009 Posts
Exactly, I just took it apart and blew the crap out of it. Mine is the truboxs mbc (I think there are other specs with it, but not sure right now.) The top came off and that's all I had to do to dissasemble it.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #10 ·
i have the parts for saab one and i took the hole thing about wiped clean of any dirt and put it back together
 
1 - 10 of 10 Posts
Top