SaabCentral Forums banner

1 - 20 of 22 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
My 2004 Saab 9-3 has been parked for a month now. I went out one day to turn on my car and the key wouldn't turn and the display read "Steering Lock Malfunction". So over the course of a days we checked the battery, cleaned the ISM, changed the ISM, and checked all the fuses. We decided to purchase a tech 2 to decide what specifically was wrong. Once it got here we went ahead and plugged it into the car and this picture showed up.
270160

After seeing these codes I knew I needed to replace the CIM. Instead of finding another CIM with a matching key, I found this company that repairs computer modules and they mentioned no reprogramming needed. This being because it would be the same CIM but repaired. So I went ahead and sent my CIM to them so they can find the problem and fix it up. Then when it came time for me to get it back they mentioned that something was in fact wrong with the CIM. They said there was no need to open the CIM up but to flash it which I assume is to reset it. Something made the CIM fail according to them. So then they sent it back to me and once I got it back I went ahead and put it back in the car. Then I tried to start the car and the key wouldn't turn again. So we plugged in the tech 2 to see what was wrong this time and this showed up.
270161

The codes below had dissapeared but this still shows up. Now that the codes dissapeared I'm assuming that the CIM is ok now but I'm not 100% sure. Does anyone have any idea what this picture above means? Any help would be really appreciated. Thanks
 

·
Super Moderator
Joined
·
19,783 Posts
Add SCL with tech2. See what happens.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
Just to be sure of what you are telling me. Do I get another SCL or do I just try to reprogram the one that the car has already? Thank you Diggs
 

·
Super Moderator
Joined
·
19,783 Posts
go into add/remove and add it. see what it does. or remove then add. lets see what happens.
 

·
Registered
Joined
·
7,687 Posts
B1016 (00) means that CIM is from another car and VIN do not match with your car. VIN could be blank.
Try to add CIM again.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
I have a bit of an update...
So today I had a goal to add/remove either the CIM or SCL. Once I got to the modules tab on the tech 2 I only found the CIM and not the SCL, so I just attempted to add the CIM. Once I tried to added the CIM for the first time I almost finished that process but I got to this one point where it said ECU failed to add/remove. So then I went ahead and tried to add it one more time and it said I had to get security access again so I went ahead and did that again on my laptop and this popped up.
270177


Then I gave up on trying to gain access so I was just like ok let me see if i can remove the CIM instead of adding this time. I then successfully removed the CIM with the tech 2. Then I tried to add it back, so I went back to my laptop to gain security access and succeeded. Then while I was in the process of adding the CIM again, it failed to add. This time it stopped halfway after I got an ok to the security access and this popped up.
270178

Not really sure what this means but after multiple attempts of trying to add it this would just keep showing up. I will continue working on adding this tomorrow, but I need some advice. Does anyone know what I should do? I've also tried to add it about 4 time now and failed, so can this cause any problems? Does this happen sometimes or am I doing something wrong?
 

·
Registered
Joined
·
2,070 Posts
Can u turn the ignition switch to ON now ? If yes, go ahead clear all dtcs, then proceed to add the cim again and report .
By the way, make sure battery voltage stays above 12 during the whole thing
 

·
Registered
Joined
·
10 Posts
Discussion Starter #11
I've been trying to do all the advice you guys have been posting on here and no success yet. I just found another code that might be interfering with adding the CIM, but I'm not sure?
270211

Do you guys think that this might be the problem on why I'm not able to add my CIM? One day before the car stopped working it was a rainy day and I was using the wiper lever. Also when I sent my CIM to a company to fix it, they did mention that something had to cause the CIM to fail which I'm guessing could be this. I might have to go to the junkyard to get another wiper lever and see if that works and if that doesn't work then I will get a new CIM. Please tell me this is my probelm or I will cry while purchasing another CIM after spending money on getting this one fixed :'(
 

·
Registered
Joined
·
7,687 Posts
Lever itself is just stick.
You need CIM.
 

·
Registered
Joined
·
37 Posts
everyone told me I needed a cim too, but after several dozen failed attempts at adding them with a tech 2 (because the lock itself was bad) i replaced the steering column lock with a junkyard part ($15 with warranty) and never had the error (steering lock malfunction again. Thought it would be a lot harder to swap than it is. Could have saved several hundred in Tech 2 and CIMs. Just so my 2.0 could eat a lifter three months later.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #14
After multiple attempts of trying to add the CIM I got "fixed", I decided to go to the junkyard to try and find another one. I found a CIM with a matching key for $11. I went to add hat one to my car and on the first attempt I was successful. My car finally started up. I just sent an email to the company that supposedly fixed my car to get my money back. Thank you to everyone's advice on here I really appreciate it.??
 

·
Registered
Joined
·
7,687 Posts
Glad that your car is running.
 

·
Super Moderator
Joined
·
19,783 Posts
Glad you got it fixed. I know some will disagree, but I prefer the throw parts at it method when they are that cheap. $11 for a CIM with key. You robbed them blind, lol.
 

·
Registered
Joined
·
2,070 Posts
11$ !!! U should collect them from that junkyard and sell them on ebay .. i will be ur first customer
 

·
Registered
Joined
·
10 Posts
Discussion Starter #18
270342
Yea I wasn't kidding when I said I paid $11 for the CIM actually $11.32. I'm pretty sure it's because they didn't know what part it was so they charged it as an airbag clock spring.
Also one more thing I just drove my car today and this other thing popped up.
270343

It displays stability control failure. Does anyone know how to fix this or what do I need to change?
 

·
Super Moderator
Joined
·
19,783 Posts
What does tech2 say ;)
 

·
Registered
Joined
·
2,070 Posts
Hope the CIM was correct for the car and it was installed correctly, then u might need steering angle sensor calibration .
Or worse, bad CIM
 
1 - 20 of 22 Posts
Top