SaabCentral Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter · #1 ·
Hey all,
During cold starts, my car seems to idle a little strange. The idle will start off high around 1200-1500rpm for a couple of secs then drop down to below 1000 around 7 to 8, then pop back up. It does this a couple more times until it finally evens out and idles around 1100. After that, the car runs fine througout the day, even after being parked for a while. Also, this only happens after being parked overnight. I did a seach, but didnt find any idle problems exactly like mine, but usually when there are idle problems it seems to stem from a dirty throttle body. If this is a throttle body prob, does anyone have any pics as to where the throttle body is and what it looks like? Has anyone else had this problem? Sorry if this is a basic question, but any help would be greatly appreciated!!

PS- its a 02 9-3 SE automatic
 

·
Registered
Joined
·
215 Posts
I have the same kind of problem. When the weather is below 60 out, my car's idle drops down to 600 for a few seconds and the car shakes pretty badly. Then the idle comes back up and the car feels normal again. This happens until the car is warmed up, then this problem goes away. Most likely, my Idle Control valve needs to be cleaned. Its probably gummed up so when the temperatures drop the sticky stuff makes the ICV slow to respond to changing idle conditions. Look up clean icv and you'll find a bunch of posts on this issue.
 
1 - 2 of 2 Posts
Top