SaabCentral Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
434 Posts
Discussion Starter #1
Hi guys my 2011 9-5 has a weird issue.

2 weeks ago I detached my battery due to a transmission issue I had and which turned out to be nothing serious....Anyway after that incident....my panoramic sunroof can't close completely...it looks like it's closed but when I peek my head up I can see a little gap at the rear sides....I have to go out and press the sunroof down to get a complete close....any idea what's going on? needs calibration due to de-attaching of the battery?

I read the sticky re-calibration procedure and to be honest I can't understand what's it telling me to do....anyone here can describe me the "Dummy" version.
 

·
Registered
Joined
·
434 Posts
Discussion Starter #2
Bump! I am assuming no one has any issue with their panoramic sunroof?

Anyway...an update...my sunroof won't close fully...it leaves about a paper size gap which if I go out and push the sunroof then it'll close ... so I am just wondering if this is just re-learning process or "Motor issue".

Chime in?
2 cents?
 

·
Registered
Joined
·
3 Posts
Hi - I'm having the exact same sunroof issue on my 2011 9-5 turbo4. Did you get yours resolved? If so, what was it and how'd you go about fixing it? Thanks!
 

·
Registered
Joined
·
434 Posts
Discussion Starter #4
Hi - I'm having the exact same sunroof issue on my 2011 9-5 turbo4. Did you get yours resolved? If so, what was it and how'd you go about fixing it? Thanks!
Hi JP, Yes I did ..the sunroof is out of alignment ..pretty common with panoramic I heard....I did take it to a sunroof specialist shop ..they then did a reset ... only cost me an hour labor time....sorry I can't provide better solutions.
 

·
Registered
Joined
·
3 Posts
And it's now fixed? I'm OK with taking it in somewhere if it's a computer reset that's needed. Thanks for the quick response!!!
 

·
Registered
Joined
·
434 Posts
Discussion Starter #6
And it's now fixed? I'm OK with taking it in somewhere if it's a computer reset that's needed. Thanks for the quick response!!!
It's not a computer reset, I think the cable slips after a while...behind the interior lights is the motor to the sunroof..they opened that up and did something and fixed it.
 
1 - 7 of 7 Posts
Top