SaabCentral Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
207 Posts
Discussion Starter #1
Hi All,
Well after replacing the Bosche Fuel Pressure sensor, this has come back on again and stuttering and misfiring... and now out of ideas... So, I'm thinking:

What causes the P0193 code?
  • Low or no fuel - NOT HAPPENING
  • Wiring that is exposed, broken, shorted - CAN'T SEE ANYTHING
  • Fuel filter that is clogged - HOW WOULD I CHECK?
  • Defective fuel pump relay - NOT CHECKED
  • Bad fuel rail sensor - REPLACED IF THIS IS THE SAME AS THE FUEL PRESSURE SENSOR?
  • Defective fuel pump - GOING TO TEST THE PRESSURE TOMORROW
What are the symptoms of the P0193 code?
  • The Check Engine Light will come on - FLASHES THEN WENT OUT AFTER 3 BLINKS ON MOTORWAY
  • The car will not start - STARTS PERFECT
  • The car will take longer than normal to start - STARTS PERFECT
  • The car will hesitate during acceleration - WHEN PUTTING FOOT DOWN IT HESITATES AND SHUDDERS ON ACCELERATION
 

·
Registered
Joined
·
1,203 Posts
Following. No codes here but sluggish performance, lumpy idle. Replaced lots of things but not yet fuel.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
138 Posts
Iirc the previous owner of my 08 Aero was having similar issues. The fuel pump was replaced and has been fine since.

Sent from my Pixel 3a using Tapatalk
 

·
Registered
Joined
·
207 Posts
Discussion Starter #4
Iirc the previous owner of my 08 Aero was having similar issues. The fuel pump was replaced and has been fine since.

Sent from my Pixel 3a using Tapatalk
Yeah this is what I;m worried about god knows how much they cost here, need to find out
 

·
Registered
Joined
·
207 Posts
Discussion Starter #7
Yep, was the ECU and a bent pin, bent it back job done! Done 1,000 miles since and all is good :)
 
  • Like
Reactions: danjrowe27

·
Super Moderator
Joined
·
20,204 Posts
How does a pin bend without manipulating the ECU?
 

·
Registered
Joined
·
138 Posts
Yep, was the ECU and a bent pin, bent it back job done! Done 1,000 miles since and all is good :)
Excellent! I'm going to check mine.. Had a friend with long arms help me do plugs and coils and he manhandled the ecu. Wondering if I have a bent pin, maybe that would solve p0193 for me and hopefully boost issues
 

·
Registered
Joined
·
138 Posts
Welp no bent pin on my end. Just aggravation. I do have a custom 340lph fuel pump I built ready to go in though. Hopefully that takes care of the issue. Until then, any other input in what the issue could be?

Sent from my LM-V405 using Tapatalk
 
1 - 11 of 11 Posts
Top