SaabCentral Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1 (Edited)
My 04 SAAB 9-3 2.0t has a lean code, random misfire code, and a purge valve malfunction code. I did a fuel pressure test and got 10 psi while priming the pump and just under 40 psi while running. Car has intermittent misfires and bad hesitation at time. Any suggestions?
 

Attachments

·
Super Moderator
Joined
·
20,049 Posts
Do you have an aftermarket intake? Is it a 2004 or 2003?
 

·
Super Moderator
Joined
·
20,049 Posts
And you put in the 2004 ECU?

You've had that P0171 code for at least 2.5 years now..... What is the time range between the motor swap and that code?
 

·
Registered
Joined
·
31 Posts
Discussion Starter #5
And you put in the 2004 ECU?

You've had that P0171 code for at least 2.5 years now..... What is the time range between the motor swap and that code?
tell me about it man, been tryin to fix it for forever. part of me wonders why no symptoms have gotten worse. It was spittin codes right off the bat after the swap and misfiring bad till the engine would stall. This seemed to have smoothed out on its own and then the CEL was always on but i dont believe i checked the code right away. my bet is that it was a lean code.
 

·
Super Moderator
Joined
·
20,049 Posts
The 2003 has SAI and the 2004 doesn't. There is a port on the exhaust manifold for it. Since you didn't have this issue until the motor swap I think something is amiss ECU or hardware wise. Also awhile back it looks like your flexpipe was busted. Did that get fixed?

So what ECU did you use and did you update the software on it? Did you reuse the existing exhaust manifold or did you put in the 2004?
 

·
Registered
Joined
·
31 Posts
Discussion Starter #7
The 2003 has SAI and the 2004 doesn't. There is a port on the exhaust manifold for it. Since you didn't have this issue until the motor swap I think something is amiss ECU or hardware wise. Also awhile back it looks like your flexpipe was busted. Did that get fixed?

So what ECU did you use and did you update the software on it? Did you reuse the existing exhaust manifold or did you put in the 2004?

Flex pipe was repaired. My dads shop did the repair and the swap, im not sure the exact details. What are the compatibility concerns? I can contact them and get more info.
 
1 - 7 of 7 Posts
Top