SaabCentral Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi,

Last week a tractor-trailer blew a tire in front of me and my only option was to run it over because there wasn't enough time to stop and I couldn't swerve in to the other lane. When this happened it pretty much destroyed the plastic under the front bumper and my outside temp now only shows ---F. I did some research and found that the sensor is located on the front bumper and when I looked on my car it seemed to still be hanging there, but is it possible it go destroyed when I hit the tire, even though it is still plugged in?

It's a 2006 9-3 Sedan.

Any ideas would be appreciated.

Thank you!
 

·
Registered
Joined
·
202 Posts
It should be attached and not hanging. Mine went bad and was still connected. Part was inexpensive and it was and easy fix. My Saab is an 03 9-3. I would guess it is the same.
 

·
Registered
Joined
·
782 Posts
Also check the wiring between the sensor and the 10-pin under the washer bottle. A broken or corroded wire is pretty common also. Ive also thought of just mounting this sensor near the bottle anyway to keep it in a less hazardous location, but also it seems the hotter/sunnier the outdoor temp. is, the more inaccurate the reading because of the baking road surface.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
The sensor is connected to the wiring but just hanging from there. Does the actual sensor plug in somewhere, or is it usually just mounted to the bumper? Thanks
 

·
Registered
Joined
·
1,012 Posts
Sensor clips in to the centre of the lower front grille, from behind.
 
1 - 5 of 5 Posts
Top