SaabCentral Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
Hi fellow 9-5 lovers
This is my first post although I have been a SaabCentral fan since I got my 01 Aero almost 2 years ago. The car has been great a few minor problems here and there, oil pressure switch, and problems with my battery although interstate replaced for free:).....Anyways heres my current situation
88,000 miles

For the past year I noticed minor idle and surging issues. Thanks to this forum a quick cleaning of the TB (without removal) always solved the problem for at least a few months.

All was well until about a week ago I noticed the surging was coming back and was planning on a full TB cleaning. I was on my way home from school and when boosting it became a little jumpy. I then got a CEL and TCS off light. The pedal does feel different and im fairly cetain im in limp home mode(pulled the throttle cable and it revved the motor). Today after driving it a short while I popped the hood when I got home and saw what looks like oil on the TB. Its not just on the bottom its right below where the intake pipe connects and is all the way down. My oil level was a lil low but I have read most every TB thread on here and have never heard of such a thing.:confused: Ohh and my error codes were P0101, and P1260. I should note that the O-ring that goes on top of the TB has been shot since the last time I cleaned it. I also plan on cleaning the MAF, air filter, and blocking off the EVAP Check valve hose. Sorry for the long description I just want to get my baby running. I am a college student and would like to save as much money as possible by doing the repairs myself.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #2
much better

Okay so apparently I hadn't read the TB threads about the O-ring and oil in the intake. I got a new O-ring from the dealer. Of course this didnt take care of my CEL so I cleaned my MAF, air filter, TB, and also installed PCV #6 and what do you know no more CEL!!:cool:
 

·
Registered
Joined
·
1 Posts
Codes P1260 and P0101

Good to see you got a good fix.

I've just started getting the same codes, in addition to code P0455 (Evap system major leak, tried a new fuel cap with no luck.

Any way, I'll admit I'm an complete idiot, but are there any good links or help available regarding how to properly clean the my MAF, air filter, TB, etc. Preferably with pictures.

Also, I don't see any o-ring on top of my throttle body. should I have one?

2003 9-5 linear with 130,000
 

·
Registered
Joined
·
693 Posts
[....]I've just started getting the same codes, in addition to code P0455 (Evap system major leak, tried a new fuel cap with no luck.[...]
I solved my problem by spraying a little silicone lube into the Purge Solenoid. I cleared the CEL and within 3-4 days it came back. Another day or so later it went away and hasn't been back since. HTH. ;)
 
1 - 5 of 5 Posts
Top