SaabCentral Forums banner
1 - 20 of 22 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter · #1 ·
Hey guys. I'm having an oil pressure issue I believe. I just want some opinions or suggestions from past experiences. Here is what's going on.

I purchased the car with the oil pump oring leaking. So I went ahead and dropped the pan replaced the oring, cleaned the pickup screen. Replaced the oil pump.oil pump oring. Crank seal. Pcv update, valve cover gasket. Inside the engine was surprisingly very clean. Car has 170k miles. Was on the 3rd owner whom was a mechanic. Therefor I am the 4th owner. I did the above repairs because I am familiar with the issues.

Now. My car whines on startup from the oil pump area only when cold. And oil pressure light comes on at mid rpm range. Sometimes it flickers and sometimes it doesent come on at all.

Oil change was castrol syntec 530 with K and n filter.

Any help is greatly appreciated. Thanks guys
 

·
Premium Member
Joined
·
5,531 Posts
You might want to invest in an oil pressure gauge while you diagnose. The note... "And oil pressure light comes on at mid rpm range" would scare the crap out of me personally.

If you are sure the oil pressure sender/switch isn't suspect then I would be inclined to drop the pan again.
.
 

·
Registered
Joined
·
69 Posts
Discussion Starter · #5 ·
Thanks bob. I'm going to throw a new sender in it today and see what comes of it. If the issue persists I will drop the pan in the spring. I know my garret is shot. I just don't want to put the mitsubishi on with the oil pressure issue.
 

·
Registered
Joined
·
69 Posts
Discussion Starter · #8 ·
Changed the pressure switch. Problem persists. Pan will be dropped agian in spring along with oil pressure gauge. It is odd as the new oil pump is humming when cold just as the old one was.
 

·
Registered
Joined
·
1,887 Posts
I've also read of people shimming the oil pressure relief valve, which allows you to bump up the oil pressure throughout the rev range.



just a couple of washers under the spring will raise your oil pressure.
 

·
Registered
Joined
·
69 Posts
Discussion Starter · #10 ·
I did use permatex anerobic gasket sealer. I have read not to use anything but loctite. So I have this on order from eeuroparts.com as well as all new orings agian.
 

·
Registered
Joined
·
69 Posts
Discussion Starter · #12 ·
Update: ran the car today. Oil pressure is all over the place. Pulled the dipstick. Cavitation within the oil. I'm sucking air somewhere. So that means off with the pan agian.
 

·
Registered
Joined
·
7,988 Posts
did you run a ring of sealant around the pickup interface between the pan and the timing cover?

That or the O-Ring on the pickup not seated properly.

The o-rings on the crossover will be on the pressure side
 

·
Registered
Joined
·
69 Posts
Discussion Starter · #15 ·
Gentleman. After the third sump pull I am completely astonished of how much sludge was in the oil pan agian. A ball of much right under the pickup tube. New orings agian. I just don't understand I don't even drive this thing. Just hoping there isn't any damage internally there were no metal shavings in the pan.
 

·
Registered
Joined
·
1,128 Posts
nevi325,

Are you posting in the correct forum? Do you have a 9-3?
 

·
Registered
Joined
·
1,128 Posts
I have a 93 and a 95

I suggest you update the "My Saabs" section of your profile. Also when you start a thread state which car you are discussing. What year is your 9-5?
 

·
Registered
Joined
·
1,128 Posts
Ah Grasshopper you have a lot to learn. First lesson: help us to help you by providing year / model / engine. Many answers will come your way.
 
1 - 20 of 22 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top