SaabCentral Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
2007 9-3 Aero SC 181000km
270339
270340


OK, changed the oil today, and saw the filter in this condition when I took it out. Definitely collapsed.
Mobile 1 0w40 for 6500km. Fram Tough Guard filter.

When installed I am "pretty sure" it was inserted straight.

What engine condition would cause this if the install was correct. Please let it be "crap filter".

Sorry for big pictures, still learning....

Thanks
 

·
Registered
Joined
·
2,957 Posts
I think this an incorrect filter from the proportion i see .. whats its part number ?
did u make sure there is no remaining parts from the old filter ?
 

·
Super Moderator
Joined
·
9,064 Posts
filter is too tall,as the cap is tightened that happens..Same thing happens with the 2.0 filter..
 

·
Registered
Joined
·
58 Posts
Discussion Starter #4 (Edited)
I purchased 2, first box was pretty ragged with no o-ring, that filter is what you see above.
Part is TG8765 (matches what Rockauto recommends)
270341


The used filters I removed looked complete, but I didn't take a look up the engine to see if anything was stuck.

Next time I'll just seat, tighten and remove just to check if the alignment is ok.
 

·
Registered
Joined
·
6,297 Posts
Make sure you lock the filter into the cap and lube the bottom seal before installing Then the filter will rotate and not crimp
the pleats
 

·
Registered
Joined
·
58 Posts
Discussion Starter #7
Good to know for next time. Thx!
 
1 - 7 of 7 Posts
Top