SaabCentral Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hey.

I tried asking on the Finnish Saabclub forums but didn't end up getting any answers. I recently bought an OG9-3, and (surprise surprise) it's missing pixels.

I was about to order a new ribbon cable to fix it myself, when I noticed that the 2 buttons to change the time do not work unless pressed very hard, and SET + CLR do not do anything.

Is this fixable or do I need to replace the SID unit completely?
 

·
Registered
Joined
·
9,355 Posts
The system uses some kind of capacitative switch, if it's anything like the buttons on the NG900.



Since it's not working, you can safely take it apart and experiment. On the NG900, the buttons push on soft rubber bumps. Maybe there is dirt in there?
 

·
Registered
Joined
·
480 Posts
I looked into the whole ribbon repair thing when I got my OG9-3. Either DIY or sending away. Really not worth it when in the UK at least you can pick up a decent second hand unit for not very much.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
I looked into the whole ribbon repair thing when I got my OG9-3. Either DIY or sending away. Really not worth it when in the UK at least you can pick up a decent second hand unit for not very much.
Changing the ribbon cable won't be a problem for me, i'm more or less just wondering about those buttons, since the other buttons (night panel, + and -), work just fine.

I'll probably open it up and check if the there is dirt or something under the rubber nubs, but if I can't figure it out I guess i'll get a new SID unit. Would it need to be paired with Tech2? Or is it just plug and play?
 

·
Registered
Joined
·
9,355 Posts
SID units are plug and play, with the exception of convertibles needing to be programmed as such--but I think a convertible SID into a coupé would be fine.
 
1 - 7 of 7 Posts
Top