SaabCentral Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3,286 Posts
Discussion Starter #1
It sounds like a belt or pulley, but....

1. Only happens when I accelerate from a stop and continues until I disengage the clutch; it squeals for a couple of seconds after I clutch but goes away.
2. It is pretty repeatable, but the longer the trip, the less it happens.
3. It is not that loud.
4. Put some belt dressing on the belts to eliminate them as the culprit. Didn't change at all.
5. Sounds like it may be coming from the location of the belts and/or A/C and alternator. At least in that general area.
6. It does NOT happen at a standstill, so I can't find it!!

Any ideas?

Contributing factors?:

1. Degreased the engine a bit about 3 weeks ago. This has been happening for about a week.
2. It's been hot and humid here for about a week, about the length of time that this has been happening.
3. I noticed that the power steering fluid was a little low and added more fluid from a fresh bottle about the time the noise started.

I'm stumped for now. I hope that someone has an idea. Thanks in advance.
 

·
Registered
Joined
·
3,467 Posts
Load the alternator ie turn on all the lights rear screen etc, then blip the throttle, if it's the alternator belt it will squeal.
 

·
Registered
Joined
·
3,286 Posts
Discussion Starter #4
Matthew said:
Does the sound happen when you are turning the steering wheel?
Nope. Thanks to you and John above. I'll test this afternoon.
 
1 - 4 of 4 Posts
Top