SaabCentral Forums banner
1 - 5 of 5 Posts

·
Registered
2006 Saab 95 aero
Joined
·
56 Posts
Discussion Starter · #1 ·
I have a small exhaust leak, I don’t even know what type of aftermarket exhaust I got. The car is stage 3 ready (so i was told when I bought it). But it’s not tuned yet.
So if I have all these aftermarket parts that are meant for stage 3 but I’m not tuned will that be the cause of me getting 02 sensor codes? Really annoying because my mpg are at like 21 mpg, Idle is rough and loud until I clear the code. And car jerks into 2nd and 3ed gear (does not feel like transmission issues) I forgot what code it was but something about fuel too rich or lean. I’m taking it to the shop this week to get the exhaust worked on since it’s cheap and could be the cause. Do I need a tune? What’s going on? Why did he sell it without a tune but has a brew city boost sticker on The back of the car as if he had it tuned before but ended up going back to stock. I’m scared to get it tuned. What do I gotta do? Sorry if this makes no sense I’m just as lost.
 

·
Registered
'85 900; '10 9-3 ; '04 9-5; ex- 9000aero, 06' 9-3
Joined
·
164 Posts
A deleted cat, or a deleted O2 sensor would be source of the codes? Or even just a bigger pipe or a "race cat" I think can make an existing O2 sensor trip up. Im not as familiar with tuning for those items if they are deleted but suspect its possible to have that done. Or to work around anything that is deleted (defouler???) Someone smarter on this should be able to definitively explain options on that end.
 

·
Registered
2006 Saab 95 aero
Joined
·
56 Posts
Discussion Starter · #3 ·
A deleted cat, or a deleted O2 sensor would be source of the codes? Or even just a bigger pipe or a "race cat" I think can make an existing O2 sensor trip up. Im not as familiar with tuning for those items if they are deleted but suspect its possible to have that done. Or to work around anything that is deleted (defouler???) Someone smarter on this should be able to definitively explain options on that end.
Yeah I’m clueless when it comes to cars too. Previous owner said it has a race cat. Looking under the car I see there is catalytic converter. I put a defouler on bank 1 sensor 2 and everything was good my mpg went up to 27 and then few weeks later I get a bank 1 sensor 1 code. Which I know for a fact it’s not the sensor because I replaced both sensors. I’m starting to think he got this exhaust from wish or something.
 
1 - 5 of 5 Posts
Top