SaabCentral Forums banner
1 - 20 of 24 Posts

·
Registered
Joined
·
114 Posts
Discussion Starter · #1 ·
I just bought 2001 Saab 95 Turbo 2.3L
After getting couple of problems, (Invalid Idling speed, Not enough pickup and couple of error codes) I replaced, ByPass Valve, O-Ring on top of Throttle body and Turbo Boost Control Solenoid Valve, Now I get little bit better pickup then before but still not satisfactory, Turbo Gauge never goes into Red zone, even if I floor gas, another effect of Flooring and couple of miles driving is that I get error codes P1260, P0300 and P1251, and Idling RPM goes to near 2000, so as soon as I reset the error codes using OBD 2 and Torque App on my phone, the RPM comes down to normal (under 1000) but still some times the Idling RPM keeps changing like fluctuating rhythmically (when this happens the boost needle also moves little bit).

Could that be a Vacuum Leak or something else, I already changed ByPass Valve, TB O-Ring, Boost Control Solenoid Valve, Cleaned TB and Cleaned MAF.

Next weekend I am planning to test DIC and Sparkplugs , and cleaning Fuel Injectors,

Another thing I noticed while idling is little bit Whine sound, but it goes away as I drive it little bit, At red light as I stop with my foot on brake paddle, I also get hard flattering or knocking sound coming from dashboard
 

·
Registered
Joined
·
838 Posts
my car never goes in red and its fine (or at least i think it is)

get your codes worked out before you go chasing what it "could be" you are getting TB codes so test the TB, i have seen threads about the coating on the wiring inside the TB melting and shorting each other

i dont know of any test for DICs just check to see which ver you have and you have the correct plugs for your car gapped correctly


what side is the whine coming from ?

no idea about the knock
 

·
Registered
Joined
·
114 Posts
Discussion Starter · #3 ·
Apparently car don't seems to be misfiring, drives ok, although pickup is same as my Honda civic 2003, so that's why I assumed the turbo boost is not working properly, or fully and some times on idling it fluctuate RPM and Boost Guage (fluctuation is not much and not all of the times, normally comes after hard acceleration or after High RPM)
TB is an expensive part, so before replacing it I would like to fix all other issues because other issues could also result in limp-home mode and 2 error codes(not sure if its really going into limphome because 90% of times I just reset the codes and RPM comes down to normal while 10% of the time I have to reset the TB spring next to cogged wheel)

I was reading some where to test DIC with Spark Plugs, is pull out DIC and put it upside down, with spark plugs in DIC;s sockets and Earth of Spark plugs connected to battery negative, then turn the engine with self. would generate equal sparks in all 4 plugs, that would show that DIC is working.

Whine is coming from passenger side as I only hear it when passenger door is open.
 

·
Registered
Joined
·
3,951 Posts
Throwing money at it, guessing and clearing the codes is not going to solve your problem.
 

·
Registered
Joined
·
1,045 Posts
Clean your TB real good. Get inside of it to the electronics and clean those too with contact cleaner. If codes still remain, then it looks like a replacement TB will be in order. Many people have got quite a few more miles out of the TB just by a good cleaning, myself included.

Stock, your turbo needle should only go to the mark between yellow and red. And it's just displaying airmass actual.


Sent from AutoGuide.com App
 

·
Registered
Joined
·
114 Posts
Discussion Starter · #6 ·
rabbit, thanks for the reply, do you mean that i should open up the Throtle body completely and then clean it? , what about the P0300 code could that be because of TB also or something with DIC and Spark Plugs, Any recommendation on getting Cheap and good condition DIC and Throtle body? and What is this AutoGuide App, is there any app available on Windows Phone devices, Actualy i was thinking of making one OBD 2 Code reader and code clearer app for Windows Phone devices as there is not any available in Store
 

·
Registered
08 9-5 Aero
Joined
·
2,297 Posts
I just bought 2001 Saab 95 Turbo 2.3L
After getting couple of problems, (Invalid Idling speed, Not enough pickup and couple of error codes) I replaced, ByPass Valve, O-Ring on top of Throttle body and Turbo Boost Control Solenoid Valve, Now I get little bit better pickup then before but still not satisfactory, Turbo Gauge never goes into Red zone, even if I floor gas, another effect of Flooring and couple of miles driving is that I get error codes P1260, P0300 and P1251, and Idling RPM goes to near 2000, so as soon as I reset the error codes using OBD 2 and Torque App on my phone, the RPM comes down to normal (under 1000) but still some times the Idling RPM keeps changing like fluctuating rhythmically (when this happens the boost needle also moves little bit).

Could that be a Vacuum Leak or something else, I already changed ByPass Valve, TB O-Ring, Boost Control Solenoid Valve, Cleaned TB and Cleaned MAF.
I
Next weekend I am planning to test DIC and Sparkplugs , and cleaning Fuel Injectors,

Another thing I noticed while idling is little bit Whine sound, but it goes away as I drive it little bit, At red light as I stop with my foot on brake paddle, I also get hard flattering or knocking sound coming from dashboard

Not saying you don't already know but it should just hit the beginning of red not into it at full boost. If ya know, disregard. Check your intercooler hose and your oil trap check valve along backside of valve cover.
 

·
Registered
Joined
·
114 Posts
Discussion Starter · #8 ·
ok, My Boost Guage only goes up to the end of Yellow, never touched the Red,
After checking and fixing most of the Vacumme leaks in Rubber pipes, Replacing ByPass Valve, Replacing TurboBoost control Valve, I am still left with, these issues,
- Some times Rough Acceleration,
- Some times Engine Shuts Down while Ideling in Park or in Neutral, It would never shut down while in Drive with Break Applied
- Still getting these Codes P1300, P0101, P0300, P0340 and P1260

I have already ordered DIC from http://www.ebay.com/itm/261010623378?item=261010623378&viewitem=&vxp=mtr and will be replacing it with Denso Platinum Spark plugs in next week, so i hope this would clear codes P1300, P0101, P0300 ans P0340 and rough Acceleration problem, but for P1260 if any one can give any recommendations, I know its Throttle body code , I also get P1251 after i floor the padel, but i do not want to replace Throtle Body without making 100% sure that its throttle body. Could one of these above codes are result of another miner Vacumme leak?
 

·
Registered
Joined
·
8,299 Posts
ok, My Boost Guage only goes up to the end of Yellow, never touched the Red,
After checking and fixing most of the Vacumme leaks in Rubber pipes, Replacing ByPass Valve, Replacing TurboBoost control Valve, I am still left with, these issues,
- Some times Rough Acceleration,
- Some times Engine Shuts Down while Ideling in Park or in Neutral, It would never shut down while in Drive with Break Applied
- Still getting these Codes P1300, P0101, P0300, P0340 and P1260

I have already ordered DIC from http://www.ebay.com/itm/261010623378?item=261010623378&viewitem=&vxp=mtr and will be replacing it with Denso Platinum Spark plugs in next week, so i hope this would clear codes P1300, P0101, P0300 ans P0340 and rough Acceleration problem, but for P1260 if any one can give any recommendations, I know its Throttle body code , I also get P1251 after i floor the padel, but i do not want to replace Throtle Body without making 100% sure that its throttle body. Could one of these above codes are result of another miner Vacumme leak?
That is a chinese Counterfiet DI wont work for long or at all and can damage your engine as long as they take returns five it a shot, its not mynengine also, That's the wrong plugs it will kill your di. You must use NGK BCPR6ES
 

·
Registered
Joined
·
8,299 Posts
That is a chinese Counterfiet DI wont work for long or at all and can damage your engine as long as they take returns five it a shot, its not mynengine also, That's the wrong plugs it will kill your di. You must use NGK BCPR6ES
I saw on here someone was testing the AIP Electronics DI but can't find the post. They are on eBay at 121 bucks
 

·
Registered
Joined
·
3,951 Posts
If you mean; the post for the free DIC for testing? don't waste your time and money on that one; that thing started throwing all kinds of codes after a couple of 100 miles(that's when it starts to fail); got it sitting a box somewhere, I use it for testing sometimes. I did contact the poster on my results and never got a reply back.


I saw on here someone was testing the AIP Electronics DI but can't find the post. They are on eBay at 121 bucks
 

·
Registered
Joined
·
114 Posts
Discussion Starter · #12 ·

·
Registered
Joined
·
2,190 Posts
Car Quest had OEM DIC's for 259.00 with store pick up. I dont know how many they have but that is a very good deal and it is a SAAB unit.
 

·
Registered
Joined
·
114 Posts
Discussion Starter · #15 ·
Mike, Can you please find out the part number, Stock Number SKU for that DIC, I just called my Local CARQUEST here in Long Island, NY and they are saying that the Coil is for $299 and will be available tomorrow for pickup, and its NOT OEM, but does carry 6 years warranty, So can you please find out if the one you are recommending is really OEM and the price also?
 

·
Registered
Joined
·
8,299 Posts
If you mean; the post for the free DIC for testing? don't waste your time and money on that one; that thing started throwing all kinds of codes after a couple of 100 miles(that's when it starts to fail); got it sitting a box somewhere, I use it for testing sometimes. I did contact the poster on my results and never got a reply back.
Yeah that's the one AIP Electornics, saw them for sale on EBAY... I guess they don;t work but TikTnak Had one too, never heard how his worked either.

ok what about using this DIC ,
http://www.eeuroparts.com/Parts/41402/Direct-Ignition-Cassette-Black-28349955/

This one looks better as they state that they are using European Coils in there, I can return the one I ordered today, and place order from eEuroParts.com , but one thing not clear why can not I use Platinum Spark Plugs? why you are emphasizing towards NGK BCPR6ES
Yes you can use platinum if you are made of money ( I thought you were trying to save a few bucks) the correct and only platinum plugs to use are NGKPFR6H - 10 and are like 10 bucks each.
 

·
Registered
Joined
·
3,951 Posts

·
Registered
Joined
·
114 Posts
Discussion Starter · #19 ·
Jssaab you are recommending me to go for AIP Electronics DI with NGK BCPR6ES , I guess I should be Able to find AIP DI in one of the local store here to with the return receipt? so please recommend?
 
1 - 20 of 24 Posts
Top