SaabCentral Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
i just got a 86 spg and put a new battary in it checked all the vac hoses and wires and my car don't start..... lights work and everthing else but the starter won't even clik or crank help
the damn thing only has 115,000 miles on it
 

·
Registered
Joined
·
7,033 Posts
Check the negative ground, wires to the starter etc. Make sure your battery leads are on good and tight.

Have you ever started a Saab before? Compared to other cars you have to turn the key pretty hard at the end of the easy key movement to start. Also in between start attempts you have to turn it all the way off and on. But don break your key;)
 

·
Registered
Joined
·
161 Posts
Definately check the wiring on the starter....especially since you don't even get a click. May want to run a hot wire to the solenoid on that starter to see if it's good too. If you get nothing then replace the starter, if it starts then trace the wires....maybe replace the ignition switch as well.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
well first i have started a saab befor my cousin has had 8 spg's and 4 other 900's

everything is tight when i trun the key my lights and **** work just not the starter and i don't hear the fuel pumps running
 

·
Registered
Joined
·
3,286 Posts
As said above, take a look at the ignition switch. Sometimes these things get a little stiff, corroded, etc. Easy to get to, not a hard thing to inspect.
 
1 - 9 of 9 Posts
Top