SaabCentral Forums banner
1 - 1 of 1 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Hello again. This time my 2004 9-5 Arc wagon recently died on the road. I was coasting down a hill and when I started to climb up the other side the car had lost basically all power. I would press the accelerator and the rpms would go down. So I coasted to the side of the road and sat, and as soon as the car stopped moving the engine shutoff and would not start back up. So I had it towed back to my house to work on it, figured I could knock out some of the easy stuff and maybe get it fixed. It's been about a week and I'm still banging on the walls, so here's what I've done.

  • First off, car cranks, but will not start.
  • When it died on the road it gave me a p1300 code which I believe is just a generic misfire code.
  • Before getting it towed I had a roommate bring me my spare DIC so I could try that since the current one likely has 170k miles on it. My spare has 130k on it and was working when I last checked. Either way, it didn't work, car was still stuck on the side of the road, but more on that later.
  • Next I got new spark plugs from a local store since the old ones were pretty gross. I gapped and installed them and still had crank but no start.
  • So I had it towed home where the first thing I did was replace the CPS and get nice NGK spark plugs. CPS didn't work either but at least there's a nice new Bosch sensor in there.
  • Ok so maybe it's the fuel system? I poked the schrader valve on the fuel rail and some fuel sprayed out, so that was ok for the time being. I took a listen to the fuel pump under the back seat and it sounds alright.
  • I checked the fuel filter and decided it was time to replace that. So I replaced that and still had no start. I thought I had bled off enough pressure but turns out I didn't and the old filter sprayed me when I removed the bolts. Good thing I expected this and brought a face shield.
  • Car still won't start after that and there's still pressure at the rail. I pulled the brand new spark plugs out and checked to see if there was fuel. Sure enough I could smell fuel on all the plugs.
  • After that I checked if I was getting spark on the cassette. I cobbled together a grounding cable with some alligator clips and flipped over the cassette, plugged in and grounded plugs and tried to start it. Obviously it wouldn't start with the cassette removed, but there were sparks so that's alright.

  • Starting to run out of ideas I decided to replace the MAF with another newish one I had on hand that I pulled from my old car.
  • So stuck that in there and surprisingly it worked, and the car started and ran normally. Huh.
  • I let it run for a few minutes before turning it off. I swapped the cassette back to the old one since I was curious and sure enough it started and ran normally.
  • Now I thought, "ok cool, I got it." But of course I wouldn't be writing this if that was truly the case.
  • After putting everything away and getting ready to take it for a test drive to see if everything worked normally, the car again refused to start.
  • That little event at least tells me the dice, twice, and ecu are working since the car started and idled perfectly normally.

So now I'm not sure what to do. Maybe it's an injector issue or maybe a fuel pressure regulator issue. It could still be an air intake issue but I don't think so. Maybe there's a loose ground somewhere? I checked the ground on the intake manifold and the thermostat housing and those were nice and tight. No new codes have been generated since the day it died so that's not helpful either. As a side note I have ecu access and have previously enabled openSID so I can use that to get live sensor readouts if necessary.

I would appreciate help in figuring out what's wrong. Thanks in advance, ~Bishop
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top