SaabCentral Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
102 Posts
Discussion Starter · #1 ·
Hi all,

I've got a 2003 9-5 Aero wagon with power seats and power mirrors with the memory option. I can't reprogram the seat positions despite swapping out all the various modules. The seats can be commanded to go to whatever was stored in the positions when the system was working properly (which was before I owned the car). The mirrors do not change position at all based on the seat position selected, although they did briefly function for a time when I first got the car.

I've swapped out the memory button module, the power seat module (PSM) and the power mirror module (PMM), and I'm still not having any luck storing my seat and mirror positions - holding M plus a number simply moves to whatever is stored at that number, doesn't reprogram/store the desired position, and no "beep" from the SID.

For some background, at first, my power seats were doing a weird stepping motion when I tried to program the seats. For instance, if I held M and 1, the seat would sort of make a series of steps (start/stop motion) back to whatever was stored in position 1, but wouldn't actually reprogram the new, desired position. So, I swapped out the memory button module. That eliminated the weird stepping response, which I intuited to mean the memory button module was bad. However, I still could not program the seats; pressing M plus a number just moved the seats to the previously stored position, albeit in a smooth motion this time with no stepping. So, next, I swapped out the PSM; same response. Finally, I swapped out the PMM, and - again - same response. The mirror positions throughout all this remain completely unchanged regardless of which memory position I select.

Is there anything I'm overlooking before trying to figure out if I have a short in the wiring harness somewhere? It should be noted that all these "replacement" parts were pulled from various cars at the junk yard, and were not new/tested parts. It's of course possible that I swapped out bad parts for more bad parts.

Thanks in advance!
 

·
Registered
Joined
·
10,188 Posts
Have you double checked fuses (25 & 26) in dash fuse box?
 

·
Registered
Joined
·
102 Posts
Discussion Starter · #3 ·
Have you double checked fuses (25 & 26) in dash fuse box?

Hey there! Sorry for the delayed response. Yes, all my fuses are good at the moment. I haven't experienced any blown fuses with this car yet.

I've tried wiggling the harnesses to see if there's a short (without really undoing any of the cable clamps or ties that keep them in place; just what I can get to easily), and that's not giving me any indication there's an open short somewhere.
 

·
Registered
Joined
·
10,188 Posts
Have you double checked that you have intact I-bus wires in driver seat connector?
Pin 15 is green and pin 19 is white.
 
1 - 4 of 4 Posts
Top