SaabCentral Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
148 Posts
Discussion Starter · #1 ·
So I thought it was the crazy heat making my car run low on power below 2500-2800rpm as well as MPGs around 15. About half way home I got a code, misfire in #4. I got this same code right after swapping the engine last weekend, cleared it and was all good. I pulled the plugs and they look good. I cleaned the contacts on the plugs and coil packs as well. Startups have been a little week after sitting over night so I'm thinking fuel filter. Would it make sense that a clogged or nearly clogged filter would cause this?

I have read other threads about the CPS and im hoping that's not it. Although I probably have another on the motor I just pulled. Where is it located on the motor?
 

·
Registered
Joined
·
2,377 Posts
CPS would cause no hot starts, Could be a bad DIC. Also what plugs are you running and are they new? Sometimes new plugs can cause a good DIC to go bad. Maybe try a bit of dielectric grease and see if that helps a bit.
 

·
Registered
Joined
·
8,299 Posts
1304 is mis cyl 4. WHy did you need to replace the engine? Blown #4 piston? Maybe you have a bad maf or injector that you reused?
 

·
Registered
Joined
·
148 Posts
Discussion Starter · #5 ·
1304 was the code.

This morning #1 was misfiring. I'm getting woried it's a bad DI unit. I dont have an extra $200.

I replaced the motor because it was a sludge motor. It knocked something fierce.

There is a 9000 in the junkyard down the rd. It has the DI. Is it the same? I figure I can swap it and see if the problem changes or goes away.
 

·
Registered
Joined
·
8,299 Posts
1304 was the code.

This morning #1 was misfiring. I'm getting woried it's a bad DI unit. I dont have an extra $200.

I replaced the motor because it was a sludge motor. It knocked something fierce.

There is a 9000 in the junkyard down the rd. It has the DI. Is it the same? I figure I can swap it and see if the problem changes or goes away.

NO NO NO you cant use a Red DI from a 9000 on a T7 car you will surely blow the engien ( you get no knock detection. ) Try a used on on fleabay maybe
 

·
Registered
Joined
·
148 Posts
Discussion Starter · #9 ·
To be honest.... I did not check gap. I gave them quick look to see if they were clean and three them back in. I plan on doing some real hunting tomorrow though.

I plan on doing the fuel filter and moving the plugs around to see if the misfire moves with them.
 
1 - 11 of 11 Posts
Top