SaabCentral Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter · #1 ·
i had to change a front coil spring the other month but now im thinking the control arm bushing or ball joint is f**ked as im getting a nocking sound when driveing on a uneven road or going around a bend would there be a noise if there is a problem with control arm or lower ball joint,

engine light comes on when doing down hill and i apply the brakes the after 5 mins it goes off this is not happening all the time,

any ideas would help

cheers
 

·
Registered
Joined
·
595 Posts
It is possible that the swaybar link end may have failed. This would explain all of the problems that you have detailed.... Hopefully an inexpensive fix to your problem.
 

·
Registered
Joined
·
97 Posts
Discussion Starter · #3 ·
Eric in Lockport said:
It is possible that the swaybar link end may have failed. This would explain all of the problems that you have detailed.... Hopefully an inexpensive fix to your problem.
cheers
i thought that so i changed them but its still there,when i changed the front coil spring when i drove the car i heard a thud then i get the nocking sound,if i jack the car up and put my hands on on the wheel and pull and pust i get a nocking sound then i my hands on 6oclock on the wheels i get a nocking sound,if i undo the nut on the lower ball joint it dont nock,
 

·
Registered
Joined
·
21,583 Posts
Tweek's Turbos said:
When you changed the spring, did you replace the upper strut mount or the thrust bearing?
A very good question !

I'd have a pro check out your suspension and have the CEL - OBD codes read...
 

·
Registered
Joined
·
33 Posts
Hi there guys , I also have the knocking sound on warm days , I had new shocks , turn bearing and rubber top mount ( expencive) changed in the struts , I also get a thud sound if I turn the steering hard some times as I park. I have in mind to pull the front suspention strut and have a good look around over the Christmas holidays . Engine light after braking, I had mine show on a incline that I would park on, it turned our the break fluid was just on the low side and once the fluid cool down soon as I started and use the brakes (BING BONG ) engine light
 

·
Registered
Joined
·
97 Posts
Discussion Starter · #7 ·
Tweek's Turbos said:
When you changed the spring, did you replace the upper strut mount or the thrust bearing?
changed the upper strut mount and bearing,im still getting that sound,nxt things to check lower ball joint and track rod ends and anti roll bar bushes,ill keep this up dated
 

·
Registered
Joined
·
97 Posts
Discussion Starter · #8 ·
update

the knocking sound was comeing from the shock the sleeve nut it was undone,never noticed it when changeing the front coil spring,it must have just been tight then i go over a bump and then must have just worked lose,only noticed when i had a flat wheel and when on the jack i moved up the rubber so i could see the shock thats when i seen the nut was undone,,,

the car not knocking now and i am not getting a wobble on the steering wheel now,

thanks for the help
 
1 - 9 of 9 Posts
Top