SaabCentral Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
94 Posts
Discussion Starter · #1 ·
Hi Guys,

First time posting here, so be nice :)

I have recently purchased my first Saab, a 9-3 HOT SE Coupe, in a lovely yellow. I have a few questions I would like to ask...

1 - There is a harsh sound coming from the passenger side front wheel arch when going over bumps. I took it to a garage and they suggested it might be the lower control arm. Normally I would just say change it, but I am hesitant because the mechanic was showing me the RHS and not the LHS when he talked me through it :S I am going to get a second opinion, but thought I would see if anyone had any thoughts on it here.

2 - It's 1999 reg and has 124k on the clock, but it isn't as quick as I thought it would be. I used to have an Audi A4 1.8T Sport with 150BHP and that seemed quicker and had a more noticable boost from the turbo.

3 - I've heard of a few cheap mods to help the handling of the car. I am planning on getting new suspension springs and a new rear ARB, but wasnt sure which bushes to get? Also, which size would I need as they seem to be between 19mm - 22mm?

Sorry for being such a dunce with this, but any help will be much appreciated!

Cheers
John
 

·
Registered
Joined
·
3,250 Posts
welcome
which portsmouth do you live in (as in state/country)

1. have all of suspension components checked over again
2. if your 9-3 is a HOT it should be noticeably faster than the A4
3. 22mm all the way
 

·
Registered
Joined
·
94 Posts
Discussion Starter · #3 ·
I live in Portsmouth on the southcoast of the UK.

With regards to the speed of the car, im not sure what to check as it doesnt seem that quick, considering it is a HOT ( I have tripled checked this). Maybe there is a boost problem, I just dont know. I guess I have to do a little more research into it...
 

·
Registered
Joined
·
1,655 Posts
On the boost gauge does the needle go all the way into the red?
 

·
Registered
Joined
·
94 Posts
Discussion Starter · #5 ·
I have never seen it go into the red but it does go all the way on the yellow bar. I assumed going into the red would be a bad thing?
 

·
Registered
Joined
·
1,161 Posts
Have you changed the plugs? These cars are very dependent on feedback from the plugs. You need NGK PFR7H-10 - very expensive but worth it.
 

·
Registered
Joined
·
94 Posts
Discussion Starter · #7 ·
I haven't changed the plugs since I have owned the car (2 months) so I will check the history and see if they have been changed recently.

If they haven't, then I'll install some new ones. I found the ones you mentioned on Elk Parts.

Thanks for your idea's so far!
 

·
Registered
Joined
·
1,655 Posts
In 3rd and 4th gear it should slightly eneter the red at wot, if it does not then id say you have a boost leak somewhere
I have never seen it go into the red but it does go all the way on the yellow bar. I assumed going into the red would be a bad thing?
 
1 - 8 of 8 Posts
Top