SaabCentral Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
199 Posts
Discussion Starter · #1 ·
So i just returned home from a xmas trip fully aware of the need to bolt in some new pads. Luckily i had ordered some new redstuff pads from the UK before xmas and was expecting them today.

So i picked up my parcel early on in the day and when i got to settle down this evening decided to pull apart the packaging and look at my new toy.

And...

%&#%&$&%$%$^ some incompetent packer has sent the outboard pads and forgotten the inboard pads.

Now the never ending email chain, the long wait (7-10days to get it shipped...) and the squeaky brake pads ongoing...
 

·
Registered
Joined
·
22,211 Posts
How strange :confused:

You mean they have sent just 2 pads?

(Inner and outter pad faces look the same but I cant recal if there is a clip where it sits into the piston) :confused:
 

·
Registered
Joined
·
199 Posts
Discussion Starter · #3 ·
Yes, they sent me 2 pads.
The inboard pads have the clip that goes into the piston. I have none of them.

The outboard pads have the wear mark indicator. I got two of them. Left and Right.

I really have no idea how they managed it, even the weight the quoted me on freight is over half a kilo lighter and the postage is signifcantly less (2/3rds) of what i was quoted. So they didnt even notice that.

Considering the place i ordered it from specialise in brakes, really a amateur mistake
 

·
Registered
Joined
·
22,211 Posts
AdrianB said:
Yes, they sent me 2 pads.
.........

Considering the place i ordered it from specialise in brakes, really a amateur mistake
I'm gobsmacked :eek:
 

·
Registered
Joined
·
199 Posts
Discussion Starter · #5 ·
In a further random and unexpected twist the other parts arrived today in a seperate package.... weird that they'd ship them seperately...
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top