SaabCentral Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello All,

I am having a problem with my front brakes dragging. I replaced the pads and rotors (Akebono ceramics and Brembo rotors) and have been having problems getting the brakes to fully release ... I never noticed a problem before I changed them. I ended up also changing the calipers and still have the problem. (The rotors become too hot to touch after a short drive and barely using the brakes.) Any ideas of what the problem is? I double checked the caliper clips and they are on correctly. One thought I had is that maybe the flexible hoses have deteriorated internally and are restricting the return.(Had this happen on a different car.) Any help would be appreciated.

TIA.
 
G

·
I don't know if this happens in Saabs, but in other cars, when the flexible lines get old, they swell internally and have been known to create a "check valve" effect, causing the brakes either to lock or drag since the fluid is not returning to the master cylinder. If you open the bleed valve on the caliper, does the dragging stop until you apply the brakes again? If so, the problem is located before the caliper. HTH. Good luck.
 

·
Registered
Joined
·
8,293 Posts
Did you clean teh guides where the "ears" of teh pad move along as the caliper squeezes them? You shoudl grease them with brake greas ( synthetic too)

And did you clean and grease the glide pins on the caliper to the carrier, same reason
 
G

·
Jssaab said:
Did you clean teh guides where the "ears" of teh pad move along as the caliper squeezes them? You shoudl grease them with brake greas ( synthetic too)

And did you clean and grease the glide pins on the caliper to the carrier, same reason
Two very good points. Start simple first!!
 
1 - 4 of 4 Posts
Top