SaabCentral Forums banner

1 - 6 of 6 Posts

·
Registered
08' Saab 9-3 aero sportcombi 2.8l V6 FWD
Joined
·
12 Posts
Discussion Starter #1
Ive been fighting a misfire in cylinder 6 on my 08 93 aero 2.8 v6 fwd. Ive replaced the coil, sparkplug (gapped at .034), injector, and injector wiring harness. I know im getting spark out of the coul and plug and im not sure where else to look. The problem is mostly persistent but every once in a while it will start and run fine for a few miles. Otherwise its a rough idle with shuddering at acceleration. Having looked through the forums ive seen a few others encounter similar issues that were resolved by what ive already done. Inused ngk plugs and oem coils. Any help would be greatly appreciated as i thought i had it fixed when i replaced the injector harness but problem returned the following day.
 

·
Super Moderator
Joined
·
19,794 Posts
Most likely ecu then.
 

·
Registered
08' Saab 9-3 aero sportcombi 2.8l V6 FWD
Joined
·
12 Posts
Discussion Starter #3
Most likely ecu then.
I was beginning to think that, is there a way to test it to see if that is indeed the issue? If it is in fact my ecu would it be a good idea to source a used one or would that be a major gamble?
 

·
Registered
08' Saab 9-3 aero sportcombi 2.8l V6 FWD
Joined
·
12 Posts
Discussion Starter #5
Might be a silly question, what is the physical location of the cylinder you are working on?
Closest to the turbo. If im looking at the firewall closest to me and right most cylinder. As i understand my firing order starts at the firewall left most cylinder and essentially looks like this

1 3 5
2 4 6
 
1 - 6 of 6 Posts
Top