SaabCentral Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi All:

Detailed description: No sounds when I startup the car cold. Drives fine. My commute in the morning is about 11 miles and the car is obviously fully warmed up by the time I exit the freeway. When I exit and need to brake, as I slow down I hear what I can only describe as metal on metal, emanating first from the front right of the car and the sound gets louder and progresses back to the right rear of the car. When I then accelerate, the sound grinds faster with acceleration, then disappears over 20-30 mph. Once the car is warm, the sound occurs intermittently.

Any ideas?

Thanks!
 

·
Registered
Joined
·
6,332 Posts
did you put anti break squeal on? its either red stuff in a spray can or a gold paste you put it on the back side of your pads. one of my rear squeals but thats because of a bad bracket. st faustus i got a quick one for you how long did it take your springs to arrive from germany? exactly
 

·
Registered
Joined
·
536 Posts
did you put anti break squeal on? its either red stuff in a spray can or a gold paste you put it on the back side of your pads. one of my rear squeals but thats because of a bad bracket. st faustus i got a quick one for you how long did it take your springs to arrive from germany? exactly

hmm nah we didnt...maybe thats the reason.


and they took almost a month to get here...i think it was officially like 3 weeks. and im in central tx so if ur on the east coast id say a day or two earlier.....its not that shipping takes forever, its customs.
 

·
Registered
Joined
·
6,332 Posts
hmm nah we didnt...maybe thats the reason.


and they took almost a month to get here...i think it was officially like 3 weeks. and im in central tx so if ur on the east coast id say a day or two earlier.....its not that shipping takes forever, its customs.
crap they wouldent be here for carlisle w.e get some brake squeal and spray it on the back of your pads.
 

·
Registered
Joined
·
14 Posts
Have either of you driven on gravel roads recently. I have had gravel stuck in between my rotors and the shield that is on the back side of them.
 

·
Registered
Joined
·
1,695 Posts
What the....? I just got this tonight to. I slowed down to drop my friend off at his house. Then when i started to accelerate the sound increased. Also when i reverse the sound is constant and worse.
 

·
Registered
Joined
·
1,687 Posts
What the....? I just got this tonight to. I slowed down to drop my friend off at his house. Then when i started to accelerate the sound increased. Also when i reverse the sound is constant and worse.
If your's is a constant sound and not braking you could have a hub problem. First signs I got when my hub seized.
 

·
Registered
Joined
·
1,695 Posts
it sounds like theres only one specific spot scraping though. because as the wheel spins, it sounds like something is scraping a specific spot every time it goes round. but in reverse its just a constant scraping.
 
1 - 12 of 12 Posts
Top