SaabCentral Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1,252 Posts
Discussion Starter · #1 ·
well this noise is getting more noticeable i drive. whenever i accelerate and go into boost i always here a metal type noise scraping against other metal. when i picked the car up when it was new, i noticed it but was assured nothing was wrong. its been getting more noticeable and its a very odd noise not hearing the turbo but just metal scraping metal. what problems could i have and is this noise normal? i really dont want the dealer touching my car unless i have to, because the local dealer isnt that good on service.

thanks
 

·
Banned
Joined
·
631 Posts
when does the noise occur. i wouldnt be driving it if i heard metal on metal.

If it happens when you accelerate ide check to make sure your bearing in your turbo isnt about to give out.

Check to see if there is play .

More info dude. dont be driving it if its making that noise. could be serious
 

·
Registered
Joined
·
1,252 Posts
Discussion Starter · #3 ·
its just when i accelerate, but sometimes its not as noticeable. im going to take my car out and see how much it is doing it.
 

·
Registered
Joined
·
1,161 Posts
mine too

I had this 2 times. Once I picked up a small stone that lodged itself inbetween the brake disc and the guard on the inside of the disc. One back up and the stone came out and the problem was resolved.:confused:
Last week it was worse. I did pick up something somewhere but it didnt go away until I asked the guy at the carwash to chk well inside the disc-guard again. He didnt find anything but pressure jet the cavity well and the problem was resolved. But we DONT know what it was:nono;

I hope yr problem is as simple.
 

·
Registered
Joined
·
91 Posts
I made a post about this issue last year (2007) and nobody knew what to make of it really. Dealer said they couldn't replicate. I heard it and could usually make it occur when entering the freeway (accelerating from ramp to 65-75 cruise). The noise would also occur if whilst on the freeway if I let my foot off the accelerator and then pressed it shortly thereafter. It would last only 10 seconds at the most usually.. maybe sometimes longer. I forget now. The noise always seemed to come from the front driver area.

I was at the time using HESS gasoline (the cheapest around here) when the noises started and I had never used HESS before. the noises started a few days after I started using HESS. After the dealer couldn't figure it out I thought of the HESS issue. I then switched to Shell when the tank was empty and the noise never occured again. It's been at least six months now and the noise has not been back.

I've since moved to Arizona and only use Chevron and still no noise. I honestly believe it had to be related to bad fuel in some way.
 
1 - 6 of 6 Posts
Top