SaabCentral Forums banner
1 - 20 of 23 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
Now that I'm in the right forum...

Alright. I've got a '99 9-3 SE hatchback w/ about 98k miles. I am absolutely oblivious to anything that goes on in my car. I just turn it on and drive.:confused:

But, i am VERY obsessive over having everything in my car in working order and it's extremely difficult since I'm 16 and unable to be financially responsible for maintenance and such. I've had the car for almost exactly a year and it's been running wonderfully except for a laundry list of things I'd like to fix (myself, if possible). SO, with that said, here's some stuff you experts can help me out with. :D

1. rattling in the center console (behind the AC unit) when i turn on the car. it goes on until about 15 minutes after the car is turned off. very annoying. it gets WAY louder in cold weather (sub 40 degrees F). Any way to diagnose the problem? I haven't changed the battery since I've had it, if that's relevant.

2. around 45-65 mph (varies), the steering wheel shakes violently. i thought this could be a bent rim but i can't see anything.

*3. I have a rack on the top, against my will. I don't like it and i would LOVE to take it off. From what i can tell from the manual, it should be easy, but they're pretty rusted on after 11 yrs. :cry:

hang in there...almost through.

4. my lights! they keep going out over and over (specifically my left bright light). i know for a fact it's not the bulb since sometimes it comes back on randomly. fuse issue? most likely...
BUT that's not the only one. 90% of the time when i turn on my car, the info display says 'Rear Light Failure' and so i get out, go to the right tail light and tap it til it flicks on. how do i fix this one?

5. why does the heat/AC go on full blast when i turn on my car? just a question.

6. what kind of batteries does the key remote use? mine's out.

diagnoses/solutions/comments/criticism on my naivety GREATLY appreciated.

Thanks in advance.

-Caleb C.
 

·
Registered
Joined
·
18,382 Posts
1. is a worn bearing in the temp sensor, squirt a drop of oil on the shaft of the fan... look at the heated seat buttons and then the little "circle hole" one, that is where it is.

2. try putting the front wheels on the back and back on the front and see what it does.

3. Just take it off, if it is too rusty try some penetrating oil on the fasteners

4. Take out the orange relay in the fuse box under the hood and resolder the joints inside or replace it

6. Just take apart the key remote and get that kind of battery! I think it is a CR2032 which is probably the most common type of "button battery" there is anyway.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #3 ·
1. is a worn bearing in the temp sensor, squirt a drop of oil on the shaft of the fan... look at the heated seat buttons and then the little "circle hole" one, that is where it is.

2. try putting the front wheels on the back and back on the front and see what it does.

3. Just take it off, if it is too rusty try some penetrating oil on the fasteners

4. Take out the orange relay in the fuse box under the hood and resolder the joints inside or replace it

6. Just take apart the key remote and get that kind of battery! I think it is a CR2032 which is probably the most common type of "button battery" there is anyway.
1. easy enough.

2. excellent idea. i never thought to rotate...

3. i dont know if its that easy to take off. does it unscrew or is it bolted on or something? from the manual, it looks like it slides to the side then comes off?

4. where exactly is the fuse box? does it look like the one that is to the left of the steering wheel behind that panel?

6. i'm an idiot. :roll:
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #4 ·
alright. i figured out the whole fuse deal. pretty simple, actually. i switched the right high beam with the left and it did nothing so i know its not the fuse. probably some wiring since changing the bulb doesn't help either.
once thing i did notice was that a few of the 10 amp fuses had 15s in them. i couldnt recognize any problem with those functions but i was just curious...

unfortunately oil (WD-40) didnt work on the internal temp sensor. and i caked it on there...
is there any way to deactivate it or remove its fuse? is it really THAT important?
or should i just keep trying....?

i think my brake/tail light issue is something to do with the bulb holder because when i took took IT out (bulbs still attached and lit up), i could barely tap it and it would flicker. it seems like it may be the wrong bulb...

i'll keep working on the rack and tires as well.

ugh. so many issues... :)

anymore advice?
 

·
Registered
Joined
·
12,355 Posts
For item number 5, set the ACC where you want it to be when you start the engine. Then press the Fan Up arrow button and ECON button simultaneously... Ron
 

·
Registered
Joined
·
1,695 Posts
#3: Is your car a three or five door? If its a three door and the rack isnt completely rusted away Ill buy it from you.
 

·
Registered
Joined
·
22 Posts
1. is a worn bearing in the temp sensor, squirt a drop of oil on the shaft of the fan... look at the heated seat buttons and then the little "circle hole" one, that is where it is.

Thanks for the temp sensor answer! I couldn't figure out what fan was still running after I shut the motor off.
 

·
Registered
Joined
·
12,355 Posts
FYI, the WIS says that the temp sensor won't sense the cabin air temp properly if the cigarette lighter or lighter cover are not installed... Ron
 

·
Registered
Joined
·
997 Posts
#3: Is your car a three or five door? If its a three door and the rack isnt completely rusted away Ill buy it from you.

Why would the 3 or 5 door matter? does the 3 door mount differently than the 5 door?

Issue 2 from above could also be a worn out half axle, but more likely is bad alignment or something.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #11 ·
FYI, the WIS says that the temp sensor won't sense the cabin air temp properly if the cigarette lighter or lighter cover are not installed... Ron
you're saying i need to get a lighter cover and it will stop?

#3: Is your car a three or five door? If its a three door and the rack isnt completely rusted away Ill buy it from you.
It's a five door. Sorry. But I couldn't get it off to send it to you anyways. ;)

-Caleb C.
 

·
Registered
Joined
·
5,905 Posts
alright. i figured out the whole fuse deal. pretty simple, actually. i switched the right high beam with the left and it did nothing so i know its not the fuse. probably some wiring since changing the bulb doesn't help either.
once thing i did notice was that a few of the 10 amp fuses had 15s in them. i couldnt recognize any problem with those functions but i was just curious...
Wait, hold up. Not fuse, relay. It is county pick up truck orange. You need to pop the hood, find the black plastic box on the drivers side corner of the engine bay, open it, and pull out the orange relay. Carefully open it, and if you know how to soilder, just touch up the connections.

You are looking for this:


And you want to heat up and freshen these once you get it apart.
 

·
Registered
Joined
·
1,695 Posts
Why would the 3 or 5 door matter? does the 3 door mount differently than the 5 door?
Different mounting. The holes in the side of the roof that the five door have are still there for mounting. The difference is that the trim above the rear window means you cant slide the bracket into them. Instead there are studs threaded in that the rear bar mounts to. The front is the same between three and five door cars.
 

·
Registered
Joined
·
5,905 Posts
:D


*3. I have a rack on the top, against my will. I don't like it and i would LOVE to take it off. From what i can tell from the manual, it should be easy, but they're pretty rusted on after 11 yrs. :cry:


-Caleb C.
Ok, find a can of what is called penetrating oil. WD 40 is sort of it's own mixture of who knows what for removing water. Penetrating oil will lubricate and disolve rust.

Then get a good pair of plyers or vice grips, grap the end of the roof bar that has the rusty nut, and turn the whole thing lefty loosy. Not just the nut but the whole rubber part too. The Pen oil can soak in for a half hour too, may make this easier.
 

·
Registered
Joined
·
21,583 Posts
Now that I'm in the right forum...

Alright. I've got a '99 9-3 SE hatchback w/ about 98k miles. I am absolutely oblivious to anything that goes on in my car. I just turn it on and drive.:confused:

But, i am VERY obsessive over having everything in my car in working order and it's extremely difficult since I'm 16 and unable to be financially responsible for maintenance and such. I've had the car for almost exactly a year and it's been running wonderfully except for a laundry list of things I'd like to fix (myself, if possible). SO, with that said, here's some stuff you experts can help me out with. :D

1. rattling in the center console (behind the AC unit) when i turn on the car. it goes on until about 15 minutes after the car is turned off. very annoying. it gets WAY louder in cold weather (sub 40 degrees F). Any way to diagnose the problem? I haven't changed the battery since I've had it, if that's relevant.
http://www.saabcentral.com/forums/showthread.php?t=117084
2. around 45-65 mph (varies), the steering wheel shakes violently. i thought this could be a bent rim but i can't see anything.

*3. I have a rack on the top, against my will. I don't like it and i would LOVE to take it off. From what i can tell from the manual, it should be easy, but they're pretty rusted on after 11 yrs. :cry:

hang in there...almost through.

4. my lights! they keep going out over and over (specifically my left bright light). i know for a fact it's not the bulb since sometimes it comes back on randomly. fuse issue? most likely...
BUT that's not the only one. 90% of the time when i turn on my car, the info display says 'Rear Light Failure' and so i get out, go to the right tail light and tap it til it flicks on. how do i fix this one? I'd ignore this for now. The message is too vague, it should state "brake lite out".. Maybe in 2020 this will be corrected.

5. why does the heat/AC go on full blast when i turn on my car? just a question. IMO, it should not do this. Perhaps a malfunction, maybe this can be correctly programmed via the Tech 2.

6. what kind of batteries does the key remote use? mine's out.
http://www.saabcentral.com/forums/showthread.php?t=160606

diagnoses/solutions/comments/criticism on my naivety GREATLY appreciated.
Wise beyond ones years = wisdom.

Thanks in advance.

-Caleb C.
six characters, more to com.
Damn, this is difficult! losing things, we need better systems. in the future, one will be able to precisely have every question answered, now, infancy is the developmental stage. ..
 

·
Registered
Joined
·
21,583 Posts
1. easy enough.

2. excellent idea. i never thought to rotate...this is one approach
Isolate the problem, if this works not, then its Hunter 8700 time operated by the experts.

3. i dont know if its that easy to take off. does it unscrew or is it bolted on or something? from the manual, it looks like it slides to the side then comes off? PB Blaster, time and patience, maybe some friendly persuasion via a BFH.

4. where exactly is the fuse box? does it look like the one that is to the left of the steering wheel behind that panel? There are more than one.
engine compartment(main), 25 mm from the battery
engine comp, secondary, next to the power brake booster(USA, England ?)
cabin, left side side of dash(a removable panel)
something like 50 fuses, ten relays and a number of control modules.
welcome to the complexity of 21st century motor vehicles.

6. i'm an idiot. :roll: no, you are not.
Good luck:cheesy:
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #17 ·
i resorted to disconnecting the interior temp fan. I'd much rather change the temperature myself than listen to that rattling...regardless of whether it can be fixed.

i got the orange relay but i can't get it open. will work on that.

annnnd my battery is dead since i left the door cracked last night... elementary mistake.:roll:
 

·
Registered
Joined
·
18,382 Posts
How are you going to change the temperature, the system is going to think it is 1000 *F inside the car :lol: Actually for now, that seems pretty good :lol:
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #19 ·
i didn't know it disabled the entire temperature system. i thought it was just for controlling the automatic climate control, which i feel like i could live without...:confused:
 

·
Registered
Joined
·
12,355 Posts
you're saying i need to get a lighter cover and it will stop?
-Caleb C.
No, I am saying that the correct cabin temp will not be sensed. The ACC may cool too much, or heat too much.

The temp sensor runs all the time the ignition is on and fills up with dust. I would pul it, clean it and lube it... Ron
 
1 - 20 of 23 Posts
Top