SaabCentral Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Hi,

I have just carried out the fix for the gearchange linkage on my 1995 900se turbo, at the same time i decided to change the clutch cable.

After this was completed and the gearchage adjusted all felt great gearchange was like new, and all gears worked including reverse.

After doing a few miles i was changing up the box and found that i could not select 4th but could get fifth.

I decided to stop and check to see everything was ok, as i stopped and selected neutral (what i thought was neutral) i let the clutch out and the car tried to pull as if it was still in gear. As we checked under the bonnet we decided to remove the selector from the gearbox and select it direct from the box. You can feel that it is in neutral but still the car is in gear.

I put the car into reverse and as you let the clutch out slowly it just stalls.

Does anyone know what the problem is with the box is it likely to need a replacement?

It feels like the box is locked up.

I did manage to select what i think is 4th and get the car home under its own power.

I find it ironic that this occurs at the same time as i do this work, any thoughts much appretiated.

Thanks Mark;oops:
 

·
Registered
Joined
·
21,583 Posts
If this gearbox is half as easy to work on as the '80 Chevrolet Citation was , then simply pull it, crack it open and replace all the synchronizers.

Biggest problem was finding the repair parts.
Minds were blown when I asked at the Chevrolet dealer for synchros for the Citation four speed...
 

·
Registered
Joined
·
487 Posts
does it go into the gear with the car off?? i just pulled the transmission in mine> about a 2 hour job with air tools. and put a new clutch cable in. if you can get it in gear i'd say that your clutch cable isn't disengaging fully. if you can't. then i'd check the alignment of the shifter again and see oif that helps. worst case it's 4+ hours to get out and in.
 
1 - 3 of 3 Posts
Top