SaabCentral Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
217 Posts
Most of the time its the AMP1 that fails and since its on a fiber optic loop, when any part of it fails (amp, radio unit, CD player), the whole thing won't even turn on.

In my experience its the AMP1 at least 90% of the time. It's located under the driver's seat close to the door. They often fail when you get them wet at all, so it was an unfortunate placement by Saab. Any chance you got water on it?
 

·
Registered
Joined
·
217 Posts
Yes, it acctually happened as I was driving through downpour but there is nothing wet in there.
Interesting.

There's a way you can test it: if you complete the fiber optic loop it will turn on. So by removing the AMP1, and putting a piece of FO cable across the connector's two fiber connections (In and Out), the loop will close.

I've included a picture of the connector (the one that comes from the car and goes to the AMP1). You need to find a small length of fiber optic cable and have one end right up against each of the two connection points (on the left of the picture). If you do it right and press the stereo power button it'll turn on *if* the AMP1 is the problem, you just won't be driving the door speakers with no AMP1.
 

Attachments

·
Registered
Joined
·
417 Posts
Discussion Starter #5
Interesting.

There's a way you can test it: if you complete the fiber optic loop it will turn on. So by removing the AMP1, and putting a piece of FO cable across the connector's two fiber connections (In and Out), the loop will close.

I've included a picture of the connector (the one that comes from the car and goes to the AMP1). You need to find a small length of fiber optic cable and have one end right up against each of the two connection points (on the left of the picture). If you do it right and press the stereo power button it'll turn on *if* the AMP1 is the problem, you just won't be driving the door speakers with no AMP1.

Thanks for the hint, I will try that. This is exactly the type of troubleshooting hints I need.
 

·
Registered
Joined
·
283 Posts

·
Registered
Joined
·
417 Posts
Discussion Starter #10
Thanks all who replied but it seams that I will need AMP1 replacement.
Didn't drive for more than 24 hours and battery is now drained to not being able to start the car this morning. What ever happened to AMP1 is causing electrical leak. Will have to fix this soon.


Still waiting for FO jumper to be able to take out AMP1 completely out.
 

·
Super Moderator
Joined
·
20,204 Posts
Why replace it if you plan to loop past it?
 
1 - 12 of 12 Posts
Top