SaabCentral Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
174 Posts
Discussion Starter · #1 ·
Something under my hood had been getting steadily noisier the last week (not worryingly loud, just 'not normal') and yesterday it became an unpleasant intermittent grinding followed by total loss of assisted steering. I'm thinking the noise could be the bearings in the steering pump, the gaiters on the rack are fine and there's no loss of fluid from the reservoir and the serpentine belt is fairly new too.
I noticed that some fluid seems to have been thrown up by the belt spinning, not a huge amount, just light splatters. Is this the pump dying or something else?
 

·
Registered
Joined
·
3,938 Posts
When the serpentine belt was replaced did you have the idler/tensioner pulley bearing checked and replaced if worn?

This component fails regularly. The power steering pump bearings might fail but I've not heard of that.
 

·
Registered
Joined
·
174 Posts
Discussion Starter · #3 ·
The noise I was hearing was definitely steering related on it's last outing and is certainly coming from the pump, that combined with the loss of power - it all points to a (rare) pump failure.
The belt was changed just before I bought the car and the seller said he'd had everything done at the main dealer so I assume it's all kosher. However I plan on replacing all of that when I do it's 90K service next month.

I've found a replacement steering pump today for a reasonable sum so we'll see if that achieves anything. If it doesn't, you'll find me weeping in a quiet corner somewhere.
 

·
Registered
Joined
·
2,026 Posts
I had one fail so bad that the shaft, seal and bearing were hanging out of the housing.

And that's just what it looked like at first - a light spattering of oil all over the RH side of the engine compartment.
 

·
Registered
Joined
·
174 Posts
Discussion Starter · #5 ·
Update;
Now there's just a small amount of fluid left in the steering fluid reservoir and it seems to have leaked down over the CV joint and onto the lower suspension arm. I know the CV boot is sound and it's not an oil leak from the block so i'm assuming it must be fluid evacuating from the pump itself. The rack gaiters are dry, as is the rack itself - all the leaking seems centered around the pump.
I'm not gonna have chance to change the pump for the next few days (moving house) and I don't have any steering fluid anyway - am I right in thinking i'll kill the car if I drive it?

Also any recommendations for the correct fluid? Dexron III if memory serves? I see PFS stock it (not cheap) but is there anything more widely available that can be used as an alternative? I'm UK based if you hadn't guessed already.
 

·
Registered
Joined
·
3,938 Posts
santeria600; - am I right in thinking i'll kill the car if I drive .[/QUOTE said:
no but you might kill yourself. Modern cars just cannot be driven without power steering assist. Same for brakes.

There is a possibility the pump may just fail catastrophically and take out the drive belt and maybe the idler/tensioner but by far the bigger risk is of an accident due to inability to steer quickly in an emergency. Just don't unless the power steering assist can be relied on to work 100% of the time.
 
1 - 7 of 7 Posts
Top