SaabCentral Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1 (Edited)
I have a 2003 9-3 Linear. This morning I went to start it and it would not start. The check engine light was on with no SID indications. I jumpstarted it and drove it for a second thinking I may have left a light on and the battery died. It was very sluggish and produced probably 30% of its normal power at low rpms. At high RPMs it was acting closer to normal but still not where it should be. I returned home and turned the car off again and it won't start again. I took it to the local auto parts place to have them check the new battery and they say it is good with a solid charge. I attempted to start it again and it wouldn't start. (EDIT: He took the battery out and hooked it up to a charger to be 100% sure it was fully charged - so I don't think it is an electrical issue.) He then hooked up the portable charger for extra juice while starting and it still wouldn't start. I then hooked up the jumper cables to another car and it started and is still producing partial power. They checked the code and it comes up "P0638 throttle actuator control range performance".

I know both issues are addressed in these forums but I couldn't find a thread that had both loss of power and the P0638 Code.

The auto parts people seemed the be convinced its the starter. That makes sense outside of the partial power problem. Anyone have any ideas?
 

·
Registered
Joined
·
12,352 Posts
With the engine running, I would check the output of the alternator at the battery terminals with a multi-meter. The alternator should be putting out +14 VDC or better. if you read +12.6 VDC or less, the alternator is not charging the battery. Get to the point where the engine starts reliabily, then look for the poor performance problem... Ron
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
Thanks for the info. Would you still believe I should check that that if I had posted that we did charge the battery to full and it wouldn't start even then. I didn't post it correctly initially - the battery was full when I got there - was charged to be sure - and still won't start after - would that still potentially lead to an alternator?
 
1 - 4 of 4 Posts
Top