SaabCentral Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello everyone,

First time poster, long time Saab owner. I've had a few saab's in the past, 1999 900 5 speed, 2001 9-5 Wagon 2.3T, and now I have a 2009 9-3 Sportcombi XWD. I have wanted one of these for a long time, and I'm really excited to be working on it to get it fixed up and working 100%.

My first thing I can't figure out on my own however are these LED's in the back of the switches. Specifically the Headlight switch and Dimmer/Sport mode switch. When it is dark out, headlights are on, and everything else in the car is illuminated, I don't have any backlighting on these switches and I cannot see which button is what. But when I pull the switch apart, I can clearly see LED's on the PCB.

Are these activated by some specific setting in the car? Are they activated by a sensor? Or could they some how just be dead in certain parts of the PCB and not others (the airbag LED's work, but everything else does not).

Any help on this would be appreciated!
 

·
Registered
Joined
·
7,181 Posts
Hi and welcome to SC.
You have either illumination wire/connector issue or illumination led or serial resistor issue in PCB.
Have you turned illumination to max?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I've adjusted the dimmer to max with the headlights turned on, and I still haven't seen the LED's light up on the headlight switch. what would I look for next? The headlight switch operates normally (front fog, rear fog, DRL, etc, all work).
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
is it normal to change these LED's? or their resistors? Are they known for going out?
 
1 - 6 of 6 Posts
Top