SaabCentral Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
213 Posts
Discussion Starter · #1 ·
My engine surges/vibrates bad when I shift into reverse. If i give it some gas, it is smooth like it should be. The surging only happens about 80% of the time. I have replaced the cps, throttle body, DI, all motor mounts except for the rear which appears to be fine. Any clues as to what this problem is?

The local saab mechanic was stumped and I dont like dealers. I am out of options and don't know what else it could be.
 

·
Registered
Joined
·
1,470 Posts
stalknace said:
My engine surges/vibrates bad when I shift into reverse. If i give it some gas, it is smooth like it should be. The surging only happens about 80% of the time. I have replaced the cps, throttle body, DI, all motor mounts except for the rear which appears to be fine. Any clues as to what this problem is?

The local saab mechanic was stumped and I dont like dealers. I am out of options and don't know what else it could be.
Same thing happen to my 9-5.. well i should say use to happen.. i changed my sparkplugs the other day and wallaa the trembling and vibations went away you might want to try getting the saab specified plugs for your car see if that will help. good luck
 

·
Registered
Joined
·
213 Posts
Discussion Starter · #3 ·
I guess I should have said new spark plugs too which are the NGK coppers. Would spark plugs only affect reverse anyway?
 

·
Registered
Joined
·
1,470 Posts
stalknace said:
I guess I should have said new spark plugs too which are the NGK coppers. Would spark plugs only affect reverse anyway?
Not quite sure on my moms nissan it trembles a lot but that because we are 100% sure that the tranmission is going.. I am hoping thats not the cause for you. My car does tremble in reverse every mourning though when i drive the car without it reaching it's peak temperature but it doesnt happen after the car is warm though.. i am stomp i know though that there are people on here who will be able to assess your situaton. sorry
 

·
Registered
Joined
·
213 Posts
Discussion Starter · #5 ·
Yep, only reverse. In all forward gears its silky smooth.


The car is actually for sale now. If i can figure this out cheaply, since I have spent way too much already, I will keep the car.
 

·
Registered
Joined
·
1,470 Posts
stalknace said:
Yep, only reverse. In all forward gears its silky smooth.


The car is actually for sale now. If i can figure this out cheaply, since I have spent way too much already, I will keep the car.

yeah these cars take all you money.. I am a student and taking car of this car is crazy.. this summer was the worst i have to replace..fuel pump...water pump and and antenna in my ingnition somewhere and that was more than a 1000 dollars. but right now it's running smooth so im happy i hope someone can help you out man.
 

·
Registered
Joined
·
203 Posts
Get all the engine and gearbox mountings checked.
I had this in a previous car for years and I couldnt find anything wrong, then I had the exhaust replaced and the fitter found a disfunctional ;) gearbox mounting.

Pete
 
1 - 7 of 7 Posts
Top