SaabCentral Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
319 Posts
Discussion Starter #1
I've got two knock sensors in my hands and after thorough checking I can't say if any of them is OK. I did everything like Bentley says. Voltmeter set to AC, tapping with some iron stuff. Not a volt or even milivolt. Perhaps my voltmeter is not so good because at VAC scale the smallest sensitivity is 200V which of course doesn't mean than any smaller can't be measured. What am I doing wrong? No continuity even for a moment. Both of them are dead? Or should I tap it in special way?
 

·
Premium Member
Joined
·
11,587 Posts
I test mine by connecting them to the APC which I have a knock LED tuned in, then bash them with the handle of a large screwdriver. If the LED flickers, it's a goodun!
 

·
Registered
Joined
·
319 Posts
Discussion Starter #5
Knock sensor works. Plugged to the wire and tapped - solenoid chatters. Still have some questions about solenoid. If KS is OK should it chatter from time to time almost with no breaks - I can hear it when pulling out or parking car. Solenoid can be heard at low RPM's (1000-1500) until I press brake pedal then stop. There's no reason to open solenoid cause there is no boost and there should be no knocking. Is it normal?
 

·
Registered
Joined
·
91 Posts
Bartek said:
Still have some questions about solenoid. If KS is OK should it chatter from time to time almost with no breaks - I can hear it when pulling out or parking car. Solenoid can be heard at low RPM's (1000-1500) until I press brake pedal then stop. There's no reason to open solenoid cause there is no boost and there should be no knocking. Is it normal?
wires, pressure sensor or APC broken.

GR, Bennie
 

·
Registered
Joined
·
319 Posts
Discussion Starter #7
APC changed, pressure sensor gives exact 10 ohms at APC terminals (should be between 5 and 13 ohms).
 

·
Registered
Joined
·
577 Posts
Bartek said:
Knock sensor works. Plugged to the wire and tapped - solenoid chatters. Still have some questions about solenoid. If KS is OK should it chatter from time to time almost with no breaks - I can hear it when pulling out or parking car. Solenoid can be heard at low RPM's (1000-1500) until I press brake pedal then stop. There's no reason to open solenoid cause there is no boost and there should be no knocking. Is it normal?
It could be your engine timing is a bit off and the engine is knocking in that rpm-range...
 

·
Registered
Joined
·
319 Posts
Discussion Starter #9
OK. That's a clue. I'll try to swap for another solenoid and check if the other one is also chattering the same way.
 
1 - 9 of 9 Posts
Top