SaabCentral Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Has it happened to anyone else where your keyfob randomly stops working as a remote and you have to manually unlock the doors with the metal key? And the alarm goes off of course, so then you have to stick the keyfob into the ignition to turn off the alarm.

I've got a brand new 9-3 (had it less than a month) and so far it's happened twice. The batteries in the keyfob should be ok, and if they weren't the car is supposed to put up a message on the SID. Also, the times it hasn't worked I've been right next to the car, so it wasn't as if I was beyond the range. When it happens none of the buttons on the keyfob do anything, lock/unlock/trunk etc don't cause the car to do anything not even blink lights.

The second time it happened to me was tonight, I tried pushing every button quite a few times, waiting a minute or so, tried again positioning it differently around the car.


Both times after I stick the keyfob into the ignitition it disables the alarm no problem, and from then on the buttons work fine.



Really kind of annoying since when this happens the only way to get inside is to trip the alarm and wake up the neighbourhood.
 

·
Registered
Joined
·
83 Posts
It happened to me early this year as well.

I don't think it the battery. Just bring it to the dealership and they will reprogrammed the key fob for you.
 

·
Registered
Joined
·
5,873 Posts
GRIPEN said:
It happened to me early this year as well.

I don't think it the battery. Just bring it to the dealership and they will reprogrammed the key fob for you.
Ditto!

Mine wasn't working correctly and they gave me two new ones last week:D
 

·
Registered
Joined
·
98 Posts
yep me too happened to my 2003 53 plate quite a lot

had to use the key on many occasions to get in the car then the alarm went off . what a pain

switched keyfobs to other one this was fine for a while it did the same within 4 months so went back to original one

anyway sold the car now so hope it doesnt happen on the new one
 

·
Registered
Joined
·
2,617 Posts
This has happened to me 4 or 5 times. Dealer told me there was known problem and looked at the serial number on mine and said it was one that can be replaced for free. I just had one of my keys with me at the time so I have yet to get the new ones.


In the meantime, in my cases, the failures usually occur when I use the remote when too far away from the car and then it doesn't work when I try it again as I get closer.
 

·
Registered
Joined
·
2,740 Posts
only happened to me once.. dealer reprogrammed my key and its been over a year no problems... I was told it could have just been interference with the cars receiver.. not sure I believe that but o well, no problems.
 

·
Registered
Joined
·
27 Posts
Looks like the problem is still around...

Looks like the problem is still around on the MY06 9-3SS. My keyfob played dead with me today. Decides to work occasionally. Need to call dealer for an exchange. :confused:
 

·
Registered
Joined
·
1,510 Posts
I never had a problem myself, but the dealer gave me two new fobs when I brought the car in for an oil change last week.
 

·
Registered
Joined
·
366 Posts
my key fobs were replaced under the campaign, my car will go in this week and the dealer asked that I bring both keys so they can replace if need be.
 

·
Registered
Joined
·
27 Posts
Update!

My problem may have been caused by interference from satellite or radio towers.

The Saab service tech knew to ask where I experienced the problem. When I explained it was near the Time Warner cable facility at the Mililani tech park he said "Ah-Ha!". (No he didn't I'm just making that up). But he explained that the keyfob remotes work on radio frequency, and there is a lot of high power radio stuff going on in that tech park. Another Saab owner would experience the problem when parking near a local TV station.

When I asked why one of the keyfobs still didn't work when I got home, he mention that it might need to be sync'd with the ignition again. You can do that by putting the keyfob in the center ignition and turning it between Off and On 3 times (and click your heels).

So I guess the mystery is solved. I'll be more aware of radio interference from now on, but do remotes from other manufacturer's have this issue?

jonatj
 
1 - 11 of 11 Posts
Top