SaabCentral Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I have a 05 9-3 and had to unhook the battery and after I hooked it back up now the key wont turn. I'm not getting a message on the display at all, I've tried both keys and tried cranking the wheel which I read on another post. The fob is still working when I push the buttons but will not turn.
 

·
Super Moderator
Joined
·
19,138 Posts
take key out and put in a couple times so it resynchs.
 

·
Super Moderator
Joined
·
19,138 Posts
What is battery voltage?
 

·
Super Moderator
Joined
·
19,138 Posts
And did you try and jump start it for some reason? Why was battery unhooked anyways?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #9
Battery voltage after sitting all night is 12.49, the reason the battery was unhooked is because I had the abs, traction, and stability warnings all going off and know a guy that lives a ways from me with a Tech 2 and it was all from the driver rear wheel so after replacing the hub and they were still on we looked at the wiring and it had been spliced many times so I replaced the whole wiring loom on the rear and was told by a friend to unhook the battery to clear the lights when done. I must say I am the farthest thing from a mechanic but am struggling through this purchase a few months ago trying to make the Saab good but its starting to be a real pain. I am hoping there isnt anything that would of affected the ignition along that back area cuz it was a struggle to rewire all of that and just hope I didnt mess something up
 

·
Registered
Joined
·
275 Posts
... I replaced the whole wiring loom on the rear and was told by a friend to unhook the battery to clear the lights when done.
... Mr Jim? Diamond maybe you .. should have known better...;););). Just kidding,. (song reference for those of the younger generation).

Anyways..about your problem.
Are you saying disconnecting the battery cleared this? Or do you have DTCs?
I would check all fuses / see if you have lost voltage somewhere.
If you still have access, use tech 2 to check wiring harness and see whats talking.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #12
Don’t know if I still have codes cuz still won’t start, I don’t have a tech 2 and not sure what color wires I cut everything I did was on the back end of the car. Clearly I shouldn’t of tried doing anything to it but now I have the ISM out hoping just a cleaning will fix my problems cuz it was getting a little goofy and maybe it’s just a coincidence it happened at the same time, that seems to be how my luck is going with this wonderful vehicle
 

·
Registered
Joined
·
8 Posts
Discussion Starter #13
Update I cleaned the ignition module and still had no luck but ended up finding a similar one in a junkyard paid $20 for the ignition module and good as new
 

·
Registered
Joined
·
1,822 Posts
So the key doesnt move to any position, and the dash is dark.
with the key in, try to flash the high beam, does it work?
 

·
Super Moderator
Joined
·
19,138 Posts
So the key doesnt move to any position, and the dash is dark.
with the key in, try to flash the high beam, does it work?
From what I can tell he replaced the ISM and it works now. Not sure why it would just die like that.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #17
Yes I’m confused on why it died while I was working on the rear end but seems that’s what happened, I’ve only had this for maybe 6 months and already know to not question it if I can fix it cheap
 
1 - 18 of 18 Posts
Top