SaabCentral Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1,416 Posts
Discussion Starter · #1 ·
I have had this car for about 4 thousand miles, fortunately its still under warranty. I was on the highway cruise control on and the car started acting like it was running out of gas but it had half a tank. I pulled over and the car died, it would restart without any problems and I was able to limp the car home only by umping the gas pedal. Once the turbo gage got to about halfway the car would cut out almost like it flooded with fuel or something. All the gages read normal it wasn't over heating, it had a half a tank, the turbo did seem a little louder than normal like it was working overtime but none of the power was coming to the engine. In fact right when the turbo should kick in the car would cut out? I love this car I just put hp evo rims on it on friday and took a road trip in it. I drove to vermont and from vermont to connecticut on saturday and it borke down on the way home, thanks god I was only about 12 miles from home. If anyone has any answers please put your 2 cents in.
 

·
Registered
Joined
·
1,101 Posts
Hardly insightful - but it sounds like a fuel problem. Are you SURE That it has fuel in? There have been issues before now with dodgy fuel gages. Are you assuming it has fuel in because the gage tells you so, or have you put half a tank of fuel in and it is still struggling.

When the boost kicks in the injectors will try and inject more fuel - fuel shortages might mean that the fuel rail pressure drops at that point and the car shuts down.

Just a guess, but it sounds fuel related. Alternatively, you could have a blocked fuel filter or perhaps had a bad tank of fuel. These last two suggestions are long shots.

Good luck getting it fixed


PS Post a picture with your new rims on - we all love to see shiny cars with nice rims.
 

·
Registered
Joined
·
244 Posts
vectorX said:
I have had this car for about 4 thousand miles, fortunately its still under warranty. I was on the highway cruise control on and the car started acting like it was running out of gas but it had half a tank. I pulled over and the car died, it would restart without any problems and I was able to limp the car home only by umping the gas pedal. Once the turbo gage got to about halfway the car would cut out almost like it flooded with fuel or something. All the gages read normal it wasn't over heating, it had a half a tank, the turbo did seem a little louder than normal like it was working overtime but none of the power was coming to the engine. In fact right when the turbo should kick in the car would cut out? I love this car I just put hp evo rims on it on friday and took a road trip in it. I drove to vermont and from vermont to connecticut on saturday and it borke down on the way home, thanks god I was only about 12 miles from home. If anyone has any answers please put your 2 cents in.
Sounds like a problem I had a while back described in this thread: http://www.saabcentral.com/forums/showthread.php?t=25686&highlight=hose
Hoepfully, it's just the hose which is only be a 5 min fix. Good luck.
 

·
Registered
Joined
·
1,416 Posts
Discussion Starter · #4 ·
thanks for the input I'm not sure yet it was towed to saab under warranty, but I pretty sure it wasn't the gage I had just put gas in it about an hour before before it broke down so it had gas.
 

·
Registered
Joined
·
1,416 Posts
Discussion Starter · #5 ·
hey saabvec, was your turbo howling when the hose popped off? The guy at the saab shop said over the phone that he had not heard of this problem yet and that it almost sounded like a hose popped off so lets hope thats true. It needs an oil change and I'm having the faded handles replaced, hopefully I can keep the old ones I'm thinking about painting them silver to see how I like it.
 

·
Registered
Joined
·
193 Posts
Similar but unrelated ...

I had a situation in another GM vehicle, brand new, and the car died. It was a failed/faulty sensor. The sensor was reading something on the cam shaft or something. Actually the car restarted 30 min later when roadside assitance came and drove it to the dealer.
 

·
Registered
Joined
·
244 Posts
vectorX said:
hey saabvec, was your turbo howling when the hose popped off? The guy at the saab shop said over the phone that he had not heard of this problem yet and that it almost sounded like a hose popped off so lets hope thats true. It needs an oil change and I'm having the faded handles replaced, hopefully I can keep the old ones I'm thinking about painting them silver to see how I like it.
Yes, it was. Loud turbo sound but no power.
 

·
Registered
Joined
·
1,416 Posts
Discussion Starter · #8 ·
$500 to saabvec you hit the nail on the head. I spoker to saab late last night and it turns out a hose had come off the turbo so it sounds like we have had the exactl same thing happen I wonder if the clip is a bit cheap? Thanks so much for the input I'm just glad it wasn't something truly serious I really love this car I'll post some photo's of the 18" hp evos I just put on it it looks nasty with big fat tires on it.
 
1 - 8 of 8 Posts
Top