SaabCentral Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hello:

Haven't written here in a long time. The reason being that my 86 SPG was running like a champ. 200,000 miles and still does an indicated 105.

My tires were going, so I stopped by my friend's shop the other day. I needed to use the lift, so I could rotate them. When he saw the shape they were in, he volunteered up a set of new Yokahamas. That was the good part of my day.

Seeing a bunch of rust around the front passenger A-arm mount was the bad part.

Is this a terminal condition, or is there a cost-effective way to solve this problem? Does anyone market a weld in replacement?

I hate to admit it, but as a lifelong fan of Volkswagens, Porsches and BMWs, I really love this SPG. She aint pretty, but she flies! And is totally comfortable. And looks cool; as a sleeper should.

Chris Mahalick
1986 SPG
1984 911 Targa(will we ever fix the pedal cluster?)
1976? Suzuki GT-750 "Street Scrambler" (in progress for two years, why rush things?)
 

·
Registered
Joined
·
18,382 Posts
Clean the area of all corrosion, mud and other crap, then weld in some heavy gauge steel. I am not sure if there is a "drop in" replacement, there should be since this is a very common issue, but you can just weld in any kind of metal that will hold that together so to speak...

105 only?
 

·
Registered
Joined
·
2,180 Posts
this is a typical C-900 problem, and almost always on the passenger side. the battery acid drains into this area and eats the metal. road salt and the fact no one ever washes down there does not help matters... If you check your driver side you will probably find it to be in-tact, but with about 2 inches of gravel in it :lol: The rust can be corrected so long as it is not too far gone. you need someone who is good at welding and cutting out old rusty metal. there are PLENTY of people who will tell you "the car is junk and can not be fixed" you need so pay no attention to them and take it to someone who is a capable welder, it can probably be fixed in a few hours


and also, an 86 SPG should be good for 125+ :cheesy:
 

·
Moderator
Joined
·
4,637 Posts
I seem to recall a link posted here to a company who supply a patch for this particular problem. It may be on rallysaab's site along with the 'boxed control arm' stuff...
 
1 - 4 of 4 Posts
Top